summaryrefslogtreecommitdiff
path: root/net-mail/mailbase
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
commit2d446203bcf1a0db08e99abca43513d246dfa73d (patch)
treeec623bb5f1f389976977e375342ec59ff441eab7 /net-mail/mailbase
parent171a011ad3a131671aeb5a98b9e3adf219ad2865 (diff)
gentoo resync : 05.04.2018
Diffstat (limited to 'net-mail/mailbase')
-rw-r--r--net-mail/mailbase/Manifest2
-rw-r--r--net-mail/mailbase/mailbase-1.2.ebuild65
-rw-r--r--net-mail/mailbase/mailbase-1.3.ebuild66
3 files changed, 133 insertions, 0 deletions
diff --git a/net-mail/mailbase/Manifest b/net-mail/mailbase/Manifest
index e833b563a8c3..be63986312b1 100644
--- a/net-mail/mailbase/Manifest
+++ b/net-mail/mailbase/Manifest
@@ -3,5 +3,7 @@ AUX common-pamd 308 BLAKE2B 95a2b44b1bd2112da1160cf5c3f993debb85692111e046a79c14
AUX common-pamd-include 245 BLAKE2B 3c2a5133b232869a5749df49a7e1f94a51f68d3bd37037d3ea10bfab18fb48fae565304bd2eba6fc686da3f3bf71249975e8f8bc9deada66eb3665d20929020d SHA512 3516815034b419bf4fd57a43536e7a25b820013d5339cb818bbbee3f0e8e26651f6b4aefae0177240219e05010ba8a2aaf6d0337220cf176801992204c3216f0
AUX mailcap 2235 BLAKE2B 3cf2cba9c1f67feab3b63246f21f8aa78b808a42b2368add9f77c36cca8d92c13122f53663ac3fe4d8b0968a66a35803d98cce6197110f1efe08562e9f837e74 SHA512 1461deb4f065c0d1778acbbcb1e08db821740de0363d3905a569d45d459a76d8813ef1c2c052d6e84b4b9b5576c89e524ecf44a9fffd8e05e91f85eb917557b0
EBUILD mailbase-1.1.ebuild 1649 BLAKE2B ff86ef5635b5949e5206a1440f83a88470e196e582f24c3edf42df8785945478ebeb86a3a100b7bc21c67cb4b7192c4ab229c697e9b96435c4c1db23f216641a SHA512 aeb1691751341563425227aa59bb9a37d3757cd49d46b0acc6226ef5da6c10748724f30f53c27894e2f3d3e25ddaeb9dc80ad51e1e09fe954a5750b60244107f
+EBUILD mailbase-1.2.ebuild 1484 BLAKE2B 1bb6d19b998fbfcd93f0079bc5f74002ee1cf23909bddb91d27051faa9ad0b6701600d5edee61e1f0c7dd9162ebdc3989092c55243fb24bea3462d6841a0fb67 SHA512 5eb0ce61fb11fd65625cb7c5e0daabd5831a43db9c0b7a81b83d8f301fb9c88123395351cf36b84d3c66496da47bb022c59d15568089d5827f860c798a96720b
+EBUILD mailbase-1.3.ebuild 1458 BLAKE2B 835a54fe1e299fd10342d6d890ef3436b91483a9e12cfc74d4291939c0a8bb1702f9467b9b9f0687a748915fdc3bdccefedaace530d96cb4d37108a474db3e7a SHA512 60cbbe72959a4b0f7f05080765257cdc18bde09c5444acf97d19b4bfbbe70eec3b6e110cbefc382db74d1506f551d9d5e919e8b927465c70fd6ac8a951eaaeb3
EBUILD mailbase-1.ebuild 1600 BLAKE2B 7e88dbe5a9ba19db0d7d20c74d4c65aeba7eea4649e7305217c37173c8a8b7d8f8e9fe6f64c9ba6846fcd20118b3f6e7af96bb190523598c7acf634b3e678c05 SHA512 2e7f91fefd121b0bc11ca452b58dfca0775ced5052ddebabdfc4faec8e37ed7e65046f0c22180a2dc18acc64299f1859e6a67b9e7a67456052e96e08c3ae29fd
MISC metadata.xml 240 BLAKE2B eeb6099e7ebc29b81588528b970830d2461fa16783bda673672d405615e46d240dcd806b3d18b6207ef8e5365f8860aa20c304394c3f5b267c5ea4dc739cb94b SHA512 97824dbce22630efb21e647b55212b7a8a19d8e38b5bf05cb0b8078530bbbaaf4dc91284e2a11beab7dfcfb779df82b87b49d11a746c7a4f6dc71f2fda8942db
diff --git a/net-mail/mailbase/mailbase-1.2.ebuild b/net-mail/mailbase/mailbase-1.2.ebuild
new file mode 100644
index 000000000000..508f9f65781e
--- /dev/null
+++ b/net-mail/mailbase/mailbase-1.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit pam eutils user
+
+DESCRIPTION="MTA layout package"
+SRC_URI=""
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="pam"
+
+RDEPEND="pam? ( virtual/pam )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup mail 12
+ enewuser mail 8 -1 /var/spool/mail mail
+ enewuser postmaster 14 -1 /var/spool/mail
+}
+
+src_install() {
+ dodir /etc/mail
+ insinto /etc/mail
+ doins "${FILESDIR}"/aliases || die
+ insinto /etc
+ doins "${FILESDIR}"/mailcap || die
+
+ keepdir /var/spool/mail
+ fowners root:mail /var/spool/mail
+ fperms 03775 /var/spool/mail
+ dosym /var/spool/mail /var/mail
+
+ newpamd "${FILESDIR}"/common-pamd-include pop
+ newpamd "${FILESDIR}"/common-pamd-include imap
+ if use pam ; then
+ local p
+ for p in pop3 pop3s pops ; do
+ dosym pop /etc/pam.d/${p} || die
+ done
+ for p in imap4 imap4s imaps ; do
+ dosym imap /etc/pam.d/${p} || die
+ done
+ fi
+}
+
+get_permissions_oct() {
+ if [[ ${USERLAND} = GNU ]] ; then
+ stat -c%a "${ROOT}$1"
+ elif [[ ${USERLAND} = BSD ]] ; then
+ stat -f%p "${ROOT}$1" | cut -c 3-
+ fi
+}
+
+pkg_postinst() {
+ # bug 614396
+ if [[ "$(get_permissions_oct /var/spool/mail)" != "3775" ]] ; then
+ einfo "Fixing ${ROOT}var/spool/mail/ permissions"
+ chown root:mail "${ROOT}var/spool/mail/"
+ chmod 03775 "${ROOT}var/spool/mail/"
+ fi
+}
diff --git a/net-mail/mailbase/mailbase-1.3.ebuild b/net-mail/mailbase/mailbase-1.3.ebuild
new file mode 100644
index 000000000000..6a3ab7e4c86d
--- /dev/null
+++ b/net-mail/mailbase/mailbase-1.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit pam eutils user
+
+DESCRIPTION="MTA layout package"
+SRC_URI=""
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="pam"
+
+RDEPEND="pam? ( virtual/pam )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup mail 12
+ enewuser mail 8 -1 /var/spool/mail mail
+ enewuser postmaster 14 -1 /var/spool/mail
+}
+
+src_install() {
+ dodir /etc/mail
+ insinto /etc/mail
+ doins "${FILESDIR}"/aliases
+ insinto /etc
+ doins "${FILESDIR}"/mailcap
+
+ keepdir /var/spool/mail
+ fowners root:mail /var/spool/mail
+ fperms 03775 /var/spool/mail
+ dosym spool/mail /var/mail
+
+ newpamd "${FILESDIR}"/common-pamd-include pop
+ newpamd "${FILESDIR}"/common-pamd-include imap
+ if use pam ; then
+ local p
+ for p in pop3 pop3s pops ; do
+ dosym pop /etc/pam.d/${p}
+ done
+ for p in imap4 imap4s imaps ; do
+ dosym imap /etc/pam.d/${p}
+ done
+ fi
+}
+
+get_permissions_oct() {
+ if [[ ${USERLAND} = GNU ]] ; then
+ stat -c%a "${ROOT}$1"
+ elif [[ ${USERLAND} = BSD ]] ; then
+ stat -f%p "${ROOT}$1" | cut -c 3-
+ fi
+}
+
+pkg_postinst() {
+ # bug 614396
+ if [[ "$(get_permissions_oct /var/spool/mail)" != "3775" ]] ; then
+ einfo "Fixing ${ROOT}var/spool/mail/ permissions"
+ chown root:mail "${ROOT}var/spool/mail/"
+ chmod 03775 "${ROOT}var/spool/mail/"
+ fi
+}