summaryrefslogtreecommitdiff
path: root/net-mail/mailbase/mailbase-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:11:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:11:03 +0100
commit2929788def9a92c1eb237eed93fbdb0c02838bbf (patch)
tree166b01591366d3479084ea774c888bc84aaa8d4f /net-mail/mailbase/mailbase-1.4.ebuild
parentab499d7cfb9ad23e83cf7a4f5052bdf1b4c42030 (diff)
Revert "gentoo resync : 13.10.2019"
This reverts commit ab499d7cfb9ad23e83cf7a4f5052bdf1b4c42030.
Diffstat (limited to 'net-mail/mailbase/mailbase-1.4.ebuild')
-rw-r--r--net-mail/mailbase/mailbase-1.4.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-mail/mailbase/mailbase-1.4.ebuild b/net-mail/mailbase/mailbase-1.4.ebuild
new file mode 100644
index 000000000000..30ec0e15153c
--- /dev/null
+++ b/net-mail/mailbase/mailbase-1.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit pam user
+
+DESCRIPTION="MTA layout package"
+SRC_URI=""
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="pam"
+
+RDEPEND="pam? ( virtual/pam )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup mail 12
+ enewuser mail 8 -1 /var/spool/mail mail
+ enewuser postmaster 14 -1 /var/spool/mail
+}
+
+src_install() {
+ dodir /etc/mail
+ insinto /etc/mail
+ doins "${FILESDIR}"/aliases
+ insinto /etc
+ doins "${FILESDIR}"/mailcap
+ doman "${FILESDIR}"/mailcap.5
+
+ keepdir /var/spool/mail
+ fowners root:mail /var/spool/mail
+ fperms 03775 /var/spool/mail
+ dosym spool/mail /var/mail
+
+ newpamd "${FILESDIR}"/common-pamd-include pop
+ newpamd "${FILESDIR}"/common-pamd-include imap
+ if use pam ; then
+ local p
+ for p in pop3 pop3s pops ; do
+ dosym pop /etc/pam.d/${p}
+ done
+ for p in imap4 imap4s imaps ; do
+ dosym imap /etc/pam.d/${p}
+ done
+ fi
+}
+
+get_permissions_oct() {
+ if [[ ${USERLAND} = GNU ]] ; then
+ stat -c%a "${ROOT}$1"
+ elif [[ ${USERLAND} = BSD ]] ; then
+ stat -f%p "${ROOT}$1" | cut -c 3-
+ fi
+}
+
+pkg_postinst() {
+ # bug 614396
+ if [[ "$(get_permissions_oct /var/spool/mail)" != "3775" ]] ; then
+ einfo "Fixing ${ROOT}/var/spool/mail/ permissions"
+ chown root:mail "${ROOT}/var/spool/mail/"
+ chmod 03775 "${ROOT}/var/spool/mail/"
+ fi
+}