summaryrefslogtreecommitdiff
path: root/net-mail/libdbx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/libdbx
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/libdbx')
-rw-r--r--net-mail/libdbx/Manifest6
-rw-r--r--net-mail/libdbx/files/bad_c.patch41
-rw-r--r--net-mail/libdbx/libdbx-1.0.3.ebuild31
-rw-r--r--net-mail/libdbx/metadata.xml8
4 files changed, 86 insertions, 0 deletions
diff --git a/net-mail/libdbx/Manifest b/net-mail/libdbx/Manifest
new file mode 100644
index 000000000000..2e1fbb68c614
--- /dev/null
+++ b/net-mail/libdbx/Manifest
@@ -0,0 +1,6 @@
+AUX bad_c.patch 1510 SHA256 98bb61bbeebdf0ff06389965545fb48996a1a03fc3d4cff210ec888cb3573464 SHA512 f69a184369e94a4a3e11b17452380a20a2cfec69bc3e04561411707d06def37f989c105962ffc0992bcf24d7d31a2a173d34b601d586283a952c39c540847e07 WHIRLPOOL 2a2003087f73b09813facea26f2f64d954ef3e873a28478ffc66e72f5d4a2bdee236fe7e518ada72833a507365636857190df43645af3d3b4e143976ddca2160
+DIST libdbx_1.0.3.tgz 24927 SHA256 eb2a6913a9f338164b2b62a9955da974ad44c94d8bb5e7cd68e4cd6ec175a636 SHA512 619f7cb25d5742066be6f2addbd06e433502c45489f973c628ae5d26758fc9ce1185185ae48da0de30d927eae8cbc610f775e0af182b10e72ecf5619ae79ba80 WHIRLPOOL 3f2abab7dd9195978a75412b798702e4ac6460156981e03938be054c78d146404ebb4b90f0e43a6121c7b79c5a59f7fc9f257b18c85cac078f91dd5de26f0018
+EBUILD libdbx-1.0.3.ebuild 677 SHA256 36e65d58eee6fdc7a1e9ffc0ce604d6a7a663f560a1006b566710682fabbf453 SHA512 ef8d98fbf045f1d563ff25341efecc7dbfbafd7da9cca2f89f9416097fba01addb3d8d9a898c5076564b91d76206233a1fc4848527701614c8e9ec8c28499ea4 WHIRLPOOL 514ea48b1f4785ddb25cfdbac6f73e257a5780fb8b5d941b6cb875984f32e7cdaf4c50cccd233ecab4b72b4b8c99d0e2b8bad511ad533b6110f25e3c38c5859b
+MISC ChangeLog 2650 SHA256 d0115e59ef071fd61919aec247deb3dc748dc3e087aa1a46f4041d5379b52585 SHA512 5f1ace6e345b84e1d02ddcdd50e203e6150d90dc89d7c275ee85c1bb81ddaff5d69d6639a4a36211de6158e100d8e93c979eab6447464a7d46ae89f0acd023e7 WHIRLPOOL 7a4ea49169d29c42aed1571e601ad0050748ebf734481cfcb24699a9557cdb6fb0131bf7e282c9141c2ea28097e0ec8f749998be43c23aa67d33cc03935d45cd
+MISC ChangeLog-2015 985 SHA256 a897c034874018d0e4610c5d5554c0ff85f18324e8dcc54fe1203e76ce83f8de SHA512 42cb5a68644d9c6e6b2a930182621913fd7b73edce1e5585930bc11620a0029ae0e6208d7ae37c62ae5797c900e66cd26f7efdf68b31ec36a4d16ca6f241692d WHIRLPOOL d7cbd9c6eaac5f3f84f1f0104da1859faf96e4d54c6e4763013083c6893c8638ab119377d387d74a1a4a0d879657de8b5078581906ef97f6534ee4df444b83d4
+MISC metadata.xml 249 SHA256 6e0ceaae82a6af4af939e13dd2c7099825ada30c4fd067ee12e37f0ef1f1e208 SHA512 f518f234871c8565fc5a853ca72108ad7f3e7bd1f46ba91530a4a20898406dd52d6eed8fafc16551f5a040b20ec17d90860e9b3ffc28629b0f6a461166256be7 WHIRLPOOL 5e15d65f1c192a46319f9d9fbf629a6f7d032cb3efa2e20eedc030c1d5931a0b1aada045d0356403a897d96ee1707e064f5a4c356227589681dc6f82f5badff8
diff --git a/net-mail/libdbx/files/bad_c.patch b/net-mail/libdbx/files/bad_c.patch
new file mode 100644
index 000000000000..1f7dc6d8ba03
--- /dev/null
+++ b/net-mail/libdbx/files/bad_c.patch
@@ -0,0 +1,41 @@
+diff -ru libdbx_1.0.3/libdbx.c libdbx_1.0.3-new/libdbx.c
+--- libdbx_1.0.3/libdbx.c 2002-10-05 15:07:36.000000000 +0200
++++ libdbx_1.0.3-new/libdbx.c 2006-09-20 08:53:46.000000000 +0200
+@@ -485,11 +485,11 @@
+ switch (blockp.type) {
+ case 0x01: //pointer to flag
+ email->flag = 0;
+- ((int*)bufx) = &(email->flag);
++ bufx = (char **)&(email->flag);
+ readtype = CHAR_TYPE;
+ break;
+ case 0x04: //pointer to dataptr
+- ((int*)bufx) = &(email->data_offset);
++ bufx = (char **)&(email->data_offset);
+ readtype = INT_TYPE;
+ break;
+ case 0x05: //asciiz string of subject (without RE: or FWD: etc...)
+@@ -521,7 +521,7 @@
+ readtype = STRING_TYPE;
+ break;
+ case 0x12: //date - of what i'm not sure. It is in a win32 FILETIME structure. needs converting to something
+- ((struct FILETIME*)bufx) = &(email->date);
++ bufx = (char **)&(email->date);
+ readtype = W32FT_TYPE;
+ break;
+ case 0x13: //recipient's name
+Only in libdbx_1.0.3-new: libdbx.o
+Only in libdbx_1.0.3-new: readdbx
+diff -ru libdbx_1.0.3/readdbx.c libdbx_1.0.3-new/readdbx.c
+--- libdbx_1.0.3/readdbx.c 2002-10-05 15:20:25.000000000 +0200
++++ libdbx_1.0.3-new/readdbx.c 2006-09-20 08:54:10.000000000 +0200
+@@ -19,6 +19,7 @@
+ #include <getopt.h>
+ #include <time.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ #include "libdbx.h"
+ #include "common.h"
+Only in libdbx_1.0.3-new: readoe
+Files libdbx_1.0.3/timeconv.o and libdbx_1.0.3-new/timeconv.o differ
diff --git a/net-mail/libdbx/libdbx-1.0.3.ebuild b/net-mail/libdbx/libdbx-1.0.3.ebuild
new file mode 100644
index 000000000000..4f8dd3227f74
--- /dev/null
+++ b/net-mail/libdbx/libdbx-1.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+MY_PN="libdbx"
+MYFILE="${MY_PN}_${PV}.tgz"
+
+DESCRIPTION="Tools and library for reading Outlook Express mailboxes (.dbx format)"
+HOMEPAGE="https://sourceforge.net/projects/ol2mbox"
+SRC_URI="mirror://sourceforge/ol2mbox/${MYFILE}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}_${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/bad_c.patch"
+ sed -i -e 's/-g/$(CFLAGS) $(LDFLAGS)/;s|gcc|$(CC)|g' Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin readoe readdbx
+ dodoc README* AUTHORS FILE-FORMAT
+}
diff --git a/net-mail/libdbx/metadata.xml b/net-mail/libdbx/metadata.xml
new file mode 100644
index 000000000000..b96bb52b9908
--- /dev/null
+++ b/net-mail/libdbx/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">ol2mbox</remote-id>
+ </upstream>
+</pkgmetadata>