summaryrefslogtreecommitdiff
path: root/net-mail/kuvert/kuvert-2.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/kuvert/kuvert-2.0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/kuvert/kuvert-2.0.4.ebuild')
-rw-r--r--net-mail/kuvert/kuvert-2.0.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-mail/kuvert/kuvert-2.0.4.ebuild b/net-mail/kuvert/kuvert-2.0.4.ebuild
new file mode 100644
index 000000000000..18570068f804
--- /dev/null
+++ b/net-mail/kuvert/kuvert-2.0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit toolchain-funcs
+
+MY_P=${P/-/_}
+
+DESCRIPTION="An MTA wrapper that automatically signs and/or encrypts
+outgoing mail"
+HOMEPAGE="http://www.snafu.priv.at/mystuff/kuvert/"
+SRC_URI="http://www.snafu.priv.at/mystuff/kuvert/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc"
+IUSE=""
+SLOT="0"
+
+S="${WORKDIR}/${PN}"
+
+DEPEND=""
+RDEPEND="app-crypt/gnupg
+ sys-apps/keyutils
+ dev-perl/MailTools
+ dev-perl/MIME-tools
+ dev-perl/Authen-SASL
+ dev-perl/File-Slurp
+ dev-perl/Net-Server-Mail
+ virtual/perl-IO
+ virtual/perl-File-Temp
+ virtual/perl-Time-HiRes
+ dev-lang/perl
+ virtual/perl-libnet
+ virtual/mta"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc dot-kuvert README THANKS TODO
+}