summaryrefslogtreecommitdiff
path: root/net-mail/getmail/getmail-6.18.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-08 18:00:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-08 18:00:27 +0000
commit78ebdce6a16942c7081565472862ab6730321ee3 (patch)
tree91e2d66a20ff982c4ccfdb6e95573a0d4ad2b3df /net-mail/getmail/getmail-6.18.12.ebuild
parent0d96a0e47c83a107ad92e2bc90e5389f577cc9a4 (diff)
gentoo auto-resync : 08:03:2023 - 18:00:26
Diffstat (limited to 'net-mail/getmail/getmail-6.18.12.ebuild')
-rw-r--r--net-mail/getmail/getmail-6.18.12.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-mail/getmail/getmail-6.18.12.ebuild b/net-mail/getmail/getmail-6.18.12.ebuild
new file mode 100644
index 000000000000..e890841ed946
--- /dev/null
+++ b/net-mail/getmail/getmail-6.18.12.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="ssl"
+inherit distutils-r1
+
+DESCRIPTION="A mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="https://www.getmail6.org/ https://github.com/getmail6/getmail6"
+SRC_URI="https://github.com/getmail6/getmail6/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/getmail6-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_prepare_all() {
+ # Use gentoo version number (including revision) for doc dir and remove COPYING file
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}