summaryrefslogtreecommitdiff
path: root/net-mail/ezmlm-idx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
commit16449a80e28af2209916cc66d19c9a44ca2b90d9 (patch)
treeb4cfe2332c7a6c5da27b6985bf05db4508df1a92 /net-mail/ezmlm-idx
parent79599515788b85b18aa655e7b7f8cc05c1bbddd8 (diff)
gentoo resync : 20.02.2019
Diffstat (limited to 'net-mail/ezmlm-idx')
-rw-r--r--net-mail/ezmlm-idx/Manifest1
-rw-r--r--net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-mail/ezmlm-idx/Manifest b/net-mail/ezmlm-idx/Manifest
index 2db7954d6c3b..1bfd2ab6bf09 100644
--- a/net-mail/ezmlm-idx/Manifest
+++ b/net-mail/ezmlm-idx/Manifest
@@ -3,4 +3,5 @@ DIST ezmlm-idx-6.0.0.tar.gz 659996 BLAKE2B bf5f7ac0a40d1167d42ef26c4b28f95899f5a
DIST ezmlm-idx-7.0.0.tar.gz 689019 BLAKE2B 22c66a4a2fcc6c0c754061ff0d93bde8fd192266112da0516e936278610288dc11d44d1959cd135a90eacb4befa43d62f53b3bedb94e994afc13aed986834bce SHA512 c0fc35aef4a72aefa4cdaee4c1933cc00aab82ee81ad7577793952fbf57106c06e4a5844a2bbf3919ad2985d2062ba1edf8831e6aa66d7e762210e7e147210ef
EBUILD ezmlm-idx-6.0.0.ebuild 1740 BLAKE2B 268ec06ad95ed38cdb4fe02d4c36a1a10f877603a6c629c67e205ab4664cf9dfeec45d1dd9998ebe382dce754105476db2dc951ebc7420951163c2c1d9090b16 SHA512 42ffd641cd6d754f898c6d66b4026b0ec5f6492ba52b4f6799b0ef60ff0b1050e86db44886cc487c263da1a7c1d575ec0cb33842d3c47ce9cb0db00cc8713bb3
EBUILD ezmlm-idx-7.0.0-r2.ebuild 1534 BLAKE2B aacca11db0ff7d161a0c4313385c6ed2f4e5d7ce71f689ee31196a05dcba132124ac87bf399983bfd8017bce0886c2f897dedc817dc09836916e40167df2a7c2 SHA512 3fed930045f3451e4efa6fbd88ffab8b1e98f8dd2b366fbc21655194f94e3b00794c2ce57bc0bf42c84de12025f7c4172370b5658dd9a3dffe9dad5808c25474
+EBUILD ezmlm-idx-7.0.0-r3.ebuild 1429 BLAKE2B 9e5641fbaee2a744019f1fbf0882b51f27193e926facf733bb6d769b054cf91270ad1ff88304f4cad09158a1e8338664296987be248358ef39320cfd260caa43 SHA512 235a676ea6da184741f0c6d7241ac91b6489b60744673a02acef534bce02796aae3c021e3f98692f6e5f88345ff023ddcc856c80c301787d38e8338cce17f93a
MISC metadata.xml 240 BLAKE2B eeb6099e7ebc29b81588528b970830d2461fa16783bda673672d405615e46d240dcd806b3d18b6207ef8e5365f8860aa20c304394c3f5b267c5ea4dc739cb94b SHA512 97824dbce22630efb21e647b55212b7a8a19d8e38b5bf05cb0b8078530bbbaaf4dc91284e2a11beab7dfcfb779df82b87b49d11a746c7a4f6dc71f2fda8942db
diff --git a/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r3.ebuild b/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r3.ebuild
new file mode 100644
index 000000000000..a8b8d7a76fe3
--- /dev/null
+++ b/net-mail/ezmlm-idx/ezmlm-idx-7.0.0-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmail toolchain-funcs
+
+DESCRIPTION="Simple yet powerful mailing list manager for qmail"
+HOMEPAGE="http://www.ezmlm.org"
+SRC_URI="http://www.ezmlm.org/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="mysql postgres"
+
+DEPEND="mysql? ( dev-db/mysql-connector-c:0= )
+ postgres? ( dev-db/postgresql )"
+RDEPEND="${DEPEND}
+ virtual/qmail"
+REQUIRED_USE="?? ( mysql postgres )"
+
+src_prepare() {
+ default
+ echo /usr/bin > conf-bin || die
+ echo /usr/$(get_libdir)/ezmlm > conf-lib || die
+ echo /etc/ezmlm > conf-etc || die
+ echo /usr/share/man > conf-man || die
+ echo ${QMAIL_HOME} > conf-qmail || die
+
+ echo $(tc-getCC) ${CFLAGS} -I/usr/include/{my,postgre}sql > conf-cc || die
+ echo $(tc-getCC) ${CFLAGS} -Wl,-E > conf-ld || die
+
+ # fix DESTDIR and skip cat man-pages
+ sed -e "s:\(/install\) \(\"\`head\):\1 ${D}\2:" \
+ -e "s:\(./install.*\) < MAN$:grep -v \:/cat MAN | \1:" \
+ -e "s:\(\"\`head -n 1 conf-etc\`\"/default\):${D}\1:" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake it man
+
+ if use mysql; then
+ emake mysql
+ elif use postgres; then
+ emake pgsql
+ fi
+}
+
+src_install () {
+ dodir /usr/bin /usr/$(get_libdir)/ezmlm /etc/ezmlm /usr/share/man
+ dobin ezmlm-{cgi,checksub,import,rmtab}
+
+ make DESTDIR="${D}" setup || die "make setup failed"
+}