summaryrefslogtreecommitdiff
path: root/net-mail/ezmlm-idx/ezmlm-idx-7.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /net-mail/ezmlm-idx/ezmlm-idx-7.2.2.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'net-mail/ezmlm-idx/ezmlm-idx-7.2.2.ebuild')
-rw-r--r--net-mail/ezmlm-idx/ezmlm-idx-7.2.2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-mail/ezmlm-idx/ezmlm-idx-7.2.2.ebuild b/net-mail/ezmlm-idx/ezmlm-idx-7.2.2.ebuild
new file mode 100644
index 000000000000..6d5b5f6fa41a
--- /dev/null
+++ b/net-mail/ezmlm-idx/ezmlm-idx-7.2.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmail toolchain-funcs
+
+DESCRIPTION="Simple yet powerful mailing list manager for qmail"
+HOMEPAGE="https://untroubled.org/ezmlm"
+SRC_URI="https://untroubled.org/ezmlm/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="mysql postgres sqlite"
+
+DEPEND="mysql? ( dev-db/mysql-connector-c:0= )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( dev-db/sqlite:3 )"
+RDEPEND="${DEPEND}
+ virtual/qmail"
+REQUIRED_USE="?? ( mysql postgres sqlite )"
+
+src_prepare() {
+ default
+ echo /usr/bin > conf-bin || die
+ echo /usr/$(get_libdir)/ezmlm > conf-lib || die
+ echo /etc/ezmlm > conf-etc || die
+ echo /usr/share/man > conf-man || die
+ echo ${QMAIL_HOME} > conf-qmail || die
+
+ echo $(tc-getCC) ${CFLAGS} -I/usr/include/{my,postgre}sql > conf-cc || die
+ echo $(tc-getCC) ${LDFLAGS} -Wl,-E > conf-ld || die
+
+ # fix DESTDIR and skip cat man-pages
+ sed -e "s:\(/installer\) \(\"\`head\):\1 ${D}\2:" \
+ -e "s:\(./install.*\) < MAN$:grep -v \:/cat MAN | \1:" \
+ -e "s:\(\"\`head -n 1 conf-etc\`\"/default\):${D}\1:" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake it man installer
+
+ if use mysql; then
+ emake mysql
+ elif use postgres; then
+ emake pgsql
+ elif use sqlite; then
+ emake sqlite3
+ fi
+}
+
+src_install() {
+ dodir /usr/bin /usr/$(get_libdir)/ezmlm /etc/ezmlm /usr/share/man
+ default
+}