summaryrefslogtreecommitdiff
path: root/net-mail/email
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /net-mail/email
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'net-mail/email')
-rw-r--r--net-mail/email/Manifest2
-rw-r--r--net-mail/email/email-3.1.3-r1.ebuild21
-rw-r--r--net-mail/email/files/email-3.1.3-fno-common.patch32
3 files changed, 55 insertions, 0 deletions
diff --git a/net-mail/email/Manifest b/net-mail/email/Manifest
index 4aa9ccf49ff6..bbd578ac0c10 100644
--- a/net-mail/email/Manifest
+++ b/net-mail/email/Manifest
@@ -1,3 +1,5 @@
+AUX email-3.1.3-fno-common.patch 560 BLAKE2B c592ea54a13089e65cb6fd6bdcb80438f8a0f7f8734149b0b8f58649a94eb17f5cb4e87f96131e2d03ad8dc057a5c4f1bab71b64d071ec0ea565622d4d5ca834 SHA512 34bee203fa588e6ba785c331208086448b39c4bb4725b04166a165980e8b5b4c1e5d0bb87a59b540a7df0f0a3b88dd0427e715c736ef443bcb40eb3a3495f6d9
DIST email-3.1.3.tar.bz2 178396 BLAKE2B 645d1fd3f0585ce6cbe2e0f2354989f07b39c83c8d21789a94d27a9e9820ea02ec1b213080018c560c7c79ef6f8fa2b636df4f40c9bc5390321d438cf64c448e SHA512 3fc1a8aa653a519261614e54b3215b89e41273207aa63f64572c8820093922a820ecad5e939b0eadf8d4c0587be83ffcb239bb31fd959b96dcf566157420f33b
+EBUILD email-3.1.3-r1.ebuild 447 BLAKE2B 471538835dad9a4e1230771cdc6635984735cc7b70aa5cf1345f2ef9145e030dc31742e571b149ba5a17e07997b84ba1e0ce03ee1cd01f8ec7cd85eb67883d13 SHA512 a2a96961d82f57aa9544b0a347e75c76f7f55af1a968aea2ccf4ea8453b93a9ee466c774ac0737cff952b84df372746de9c8dc153eb79c44679d6fad3732cb32
EBUILD email-3.1.3.ebuild 556 BLAKE2B eab248d080b827b2526f6d0284310b0f66e2f3cdc24be511efb387b4b5e3a95d47d2360037115108f9810706d9c29153c0f73c2e27e68325b36578dc37810eb7 SHA512 c7c11d031d578bf3b5423cf1125ccb469515ecbb8be3b10afcd93f7741a864d535a546be6ec0c2ced2c9fd672a9985e10dd95b00140969210e576d24e74be5ce
MISC metadata.xml 259 BLAKE2B 340db8ab484f8fe7b7a74af660d7ef8f4d99d98b2feaaa02836808ef6da6176f6c15ea5525a097b8556d434a4c8d6a6c49d97a1deb1376edac3220b4d9a07208 SHA512 be960a9ee308ff2013fbd23ae68a484a273afb04a49490859d0bd5f01e21d176937386bb2704b6dba5599ae3c71f5c91c995a46dbb162b0925c41a025567ed81
diff --git a/net-mail/email/email-3.1.3-r1.ebuild b/net-mail/email/email-3.1.3-r1.ebuild
new file mode 100644
index 000000000000..e8b2a103b89f
--- /dev/null
+++ b/net-mail/email/email-3.1.3-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Advanced CLI tool for sending email"
+HOMEPAGE="https://github.com/deanproxy/eMail"
+SRC_URI="http://www.cleancode.org/downloads/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~x86"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.3-fno-common.patch
+)
+
+src_install() {
+ default
+ doman email.1
+ dodoc README TODO
+}
diff --git a/net-mail/email/files/email-3.1.3-fno-common.patch b/net-mail/email/files/email-3.1.3-fno-common.patch
new file mode 100644
index 000000000000..ecbc43d34137
--- /dev/null
+++ b/net-mail/email/files/email-3.1.3-fno-common.patch
@@ -0,0 +1,32 @@
+--- a/include/email.h
++++ b/include/email.h
+@@ -61,11 +61,11 @@
+
+
+ /* Globally defined vars */
+-dhash table;
+-char *conf_file;
+-dstrbuf *global_msg;
++extern dhash table;
++extern char *conf_file;
++extern dstrbuf *global_msg;
+
+-struct mailer_options {
++extern struct mailer_options {
+ bool verbose;
+ bool encoding;
+ short html;
+--- a/src/email.c
++++ b/src/email.c
+@@ -40,6 +40,11 @@
+ #include "error.h"
+ #include "mimeutils.h"
+
++dhash table;
++char *conf_file;
++dstrbuf *global_msg;
++struct mailer_options Mopts;
++
+ static void
+ defaultDestr(void *ptr)
+ {