summaryrefslogtreecommitdiff
path: root/net-mail/dbmail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
commit2d446203bcf1a0db08e99abca43513d246dfa73d (patch)
treeec623bb5f1f389976977e375342ec59ff441eab7 /net-mail/dbmail
parent171a011ad3a131671aeb5a98b9e3adf219ad2865 (diff)
gentoo resync : 05.04.2018
Diffstat (limited to 'net-mail/dbmail')
-rw-r--r--net-mail/dbmail/Manifest1
-rw-r--r--net-mail/dbmail/dbmail-3.2.3-r2.ebuild135
2 files changed, 136 insertions, 0 deletions
diff --git a/net-mail/dbmail/Manifest b/net-mail/dbmail/Manifest
index f24f7351f341..e60c4e437c53 100644
--- a/net-mail/dbmail/Manifest
+++ b/net-mail/dbmail/Manifest
@@ -6,5 +6,6 @@ DIST dbmail-3.2.2.tar.gz 2444241 BLAKE2B 0fb601e66aa0b41b85c0d4ad4cb6cec6e09358c
DIST dbmail-3.2.3.tar.gz 2444227 BLAKE2B baa812fb3e925e6d896762596426208fc2ac5fcb01cb8100cfbd0464f1342f934c099ca52fd857e05fc82b97227155e9dcfc987d6c9b5c37e7daf21b167c9841 SHA512 29cc89830278f2ff28a4221fc81d4ff13cc371fbca7fb51d5376e9243234220b552cb4b6ec035c150e6cfa178435c4f36b9ce132fc02334bc6cdeb1a41c8ed85
EBUILD dbmail-3.2.2.ebuild 4851 BLAKE2B 0bb2a237364f867f483e0f99dbd9eb434337f2941f5eb72e89d31c4e7e6bfd741f1b6f1f615fde1d9453935a677b7a9ed392860def571ab3c8dd3ec2f1daef17 SHA512 a94c7341158cb6d10d56c16b93d9d34f317f0cccd4cd70365267b4fac2c64dc1dea2e1d392baddf013cff7a97bcd8487c86466d8a6d6f150475baeb908349aca
EBUILD dbmail-3.2.3-r1.ebuild 4613 BLAKE2B a3a6c512bbfce63c0b878bbe4eafc6cfc9a34ce5cd3d9a38f9ea37471e6920a3996f3d6970b7d35c7d1f03c2e0124f953a0b51f90fc264c3a2c624f5ab70cb27 SHA512 c1957a239fd669a6262bc22a2fa30649640cc67af44cd29a299ea0d1bb2f5a7689fc77376123e7ede1ad5eed10554dfa8c100ff4497c5bb5ae1b3168103202b0
+EBUILD dbmail-3.2.3-r2.ebuild 4715 BLAKE2B 33e881d875c01ac66f4fab4b8b4a259be0598770eb60c706208752ffae9b1d8567677b443fe74486d8ea181a02e0f30f216ea558ded97dd2a0337e0145687ec2 SHA512 785a447392075e52020ddc95b7d44d77493e95de01da08502553070ca56a71ff4f9a3a18035f2f2eabe86fd675d87222e27a3a0c943e5839dbc143aaf1fea69b
EBUILD dbmail-3.2.3.ebuild 4853 BLAKE2B 0aaa8ad89b7c999b6c5a66c215d3152ed93bd2a895e9be4260fb246af5e3e0d60c7d19d12c65ba32ccf23613ccff88a2c4e68f01bff3961c1fae7e344b3f9694 SHA512 a52a6edfe30085c263c4f3b4b83e475917d63f68a36f765fea643a30845d0eac2ed503b499b0d0a4351426b4cee839bccd30cecaa6f22c6f80deb226aa5c7427
MISC metadata.xml 681 BLAKE2B 235beb3355fffb0d6508af4753088efa341d74a62b87481bb5012c2668ff79194796ede4e76960dd1aca3f2a4a576268a0e36eb8b83ad012418611db194cd2ce SHA512 905c493d1ec543b10a58a152a4ea78ce59e831eb477baebfef4e930c39f268f24bccacb06ebc9ddbe398da27bf222910004fc6b74712b48bc619f7dbb94c60e5
diff --git a/net-mail/dbmail/dbmail-3.2.3-r2.ebuild b/net-mail/dbmail/dbmail-3.2.3-r2.ebuild
new file mode 100644
index 000000000000..6d19833506fc
--- /dev/null
+++ b/net-mail/dbmail/dbmail-3.2.3-r2.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd versionator user
+
+DESCRIPTION="Fast and scalable sql based email services"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap sieve ssl static"
+
+DEPEND="dev-db/libzdb
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ ldap? ( >=net-nds/openldap-2.3.33 )
+ app-text/asciidoc
+ app-text/xmlto
+ app-crypt/mhash
+ sys-libs/zlib
+ dev-libs/gmime:2.6
+ >=dev-libs/glib-2.16
+ dev-libs/libevent
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_configure() {
+ econf \
+ --enable-manpages \
+ --enable-systemd \
+ --sysconfdir=/etc/dbmail \
+ $(use_enable static) \
+ $(use_with sieve) \
+ $(use_with ldap auth-ldap)
+}
+
+src_install() {
+ emake DESTDIR="${D}" SYSTEMD_UNIT_DIR="$(systemd_get_systemunitdir)" install
+
+ DOCS=( AUTHORS README.md INSTALL THANKS UPGRADING )
+ einstalldocs
+
+ docompress -x /usr/share/doc/${PF}/sql
+ dodoc -r sql
+ dodoc -r test-scripts
+ dodoc -r contrib
+ ## TODO: install other contrib stuff
+
+ sed -i -e "s:nobody:dbmail:" dbmail.conf || die
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf || die
+ sed -i -e "s:/var/run:/run/dbmail:" dbmail.conf || die
+
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ # change config path to our default and use the conf.d and init.d files from the contrib dir
+ sed -i -e "s:/etc/dbmail.conf:/etc/dbmail/dbmail.conf:" contrib/startup-scripts/gentoo/init.d-dbmail || die
+ #sed -i -e "s:exit 0:return 1:" contrib/startup-scripts/gentoo/init.d-dbmail || die
+ #sed -i -e "s:/var/run:/var/run/dbmail:" contrib/startup-scripts/gentoo/init.d-dbmail || die
+ #newconfd contrib/startup-scripts/gentoo/conf.d-dbmail dbmail
+ #newinitd contrib/startup-scripts/gentoo/init.d-dbmail dbmail
+ # use custom init scripts until updated in upstream contrib
+ newinitd "${FILESDIR}/dbmail-imapd.initd" dbmail-imapd
+ newinitd "${FILESDIR}/dbmail-lmtpd.initd" dbmail-lmtpd
+ newinitd "${FILESDIR}/dbmail-pop3d.initd" dbmail-pop3d
+ newinitd "${FILESDIR}/dbmail-timsieved.initd" dbmail-timsieved
+ sed -i -e "s:/var/run:/run:" "${D}"/etc/init.d/dbmail-* || die
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+
+ # ldap schema
+ if use ldap; then
+ insinto /etc/openldap/schema
+ doins "${S}/dbmail.schema"
+ fi
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+ fowners dbmail:dbmail /var/lib/dbmail
+ # create this through init-scripts instead of at install time (bug #455002)
+ #keepdir /run/dbmail
+ #fowners dbmail:dbmail /run/dbmail
+}
+
+pkg_postinst() {
+ elog "Please read the INSTALL file in /usr/share/doc/${PF}/"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "DBMail requires either SQLite, PostgreSQL or MySQL."
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+ echo
+ elog "Please make sure to run etc-update."
+ elog "If you get an error message about plugins not found"
+ elog "please add the library_directory configuration switch to"
+ elog "dbmail.conf and set it to the correct path"
+ elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
+ elog "A sample can be found in dbmail.conf.dist after etc-update."
+ echo
+ elog "We are now using the init script from upstream."
+ elog "Please edit /etc/conf.d/dbmail to set which services to start"
+ elog "and delete /etc/init.d/dbmail-* when you are done. (don't"
+ elog "forget to rc-update del dbmail-* first)"
+ echo
+ elog "Changed pid directory to /run/dbmail (see"
+ elog "http://www.dbmail.org/mantis/view.php?id=949 for details)"
+ echo
+ ewarn "The database config has changed to support libzdb db URI"
+ ewarn "Please check the documentation (or Bug #479664)"
+ echo
+ ewarn "The database schema has changed since 3.0.x make sure"
+ ewarn "to run the migration script"
+ echo
+ ewarn "Please be aware, that the single init-script for all services"
+ ewarn "has been replaced with seperate init scripts for the individual services."
+ ewarn "Make sure to add dbmail-(imapd|lmtpd|pop3d|timsieved) using rc-update"
+ ewarn "and remove dbmail if you want to take advantage of this change."
+ echo
+}