summaryrefslogtreecommitdiff
path: root/net-mail/checkpassword/checkpassword-0.90-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/checkpassword/checkpassword-0.90-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/checkpassword/checkpassword-0.90-r2.ebuild')
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-mail/checkpassword/checkpassword-0.90-r2.ebuild b/net-mail/checkpassword/checkpassword-0.90-r2.ebuild
new file mode 100644
index 000000000000..2b677c23353c
--- /dev/null
+++ b/net-mail/checkpassword/checkpassword-0.90-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A uniform password checking interface for root applications"
+HOMEPAGE="http://cr.yp.to/checkpwd.html"
+SRC_URI="http://cr.yp.to/checkpwd/${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="static"
+RESTRICT="mirror bindist"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-errno.patch
+ epatch "${FILESDIR}"/${PV}-head-1.patch
+
+ use static && append-ldflags -static
+}
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ make || die "Error in make"
+}
+
+src_install() {
+ into /
+ dobin checkpassword || die
+ dodoc CHANGES README TODO VERSION FILES SYSDEPS TARGETS
+}