summaryrefslogtreecommitdiff
path: root/net-mail/asmail/asmail-2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-mail/asmail/asmail-2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-mail/asmail/asmail-2.1.ebuild')
-rw-r--r--net-mail/asmail/asmail-2.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-mail/asmail/asmail-2.1.ebuild b/net-mail/asmail/asmail-2.1.ebuild
new file mode 100644
index 000000000000..ccd9e1cabdb8
--- /dev/null
+++ b/net-mail/asmail/asmail-2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="a small mail monitor similar to xbiff"
+HOMEPAGE="http://www.tigr.net"
+SRC_URI="http://www.tigr.net/afterstep/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="jpeg"
+
+RDEPEND="dev-libs/openssl
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libICE
+ x11-libs/libSM
+ jpeg? ( virtual/jpeg )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_compile() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ sed -i -e "/LIB/s/-lssl/-lssl -lcrypto/g" \
+ configure
+ tc-export CC
+ econf $(use_enable jpeg)
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+
+ newman ${PN}.man ${PN}.1
+ newman ${PN}rc.man ${PN}rc.5
+
+ insinto /usr/share/${PN}/pixmaps
+ doins pixmaps/cloud-e/*.xpm
+
+ insinto /usr/share/${PN}
+ doins -r sounds
+
+ dodoc ${PN}rc.s* CHANGES *.txt README* TODO
+}