summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-06 16:33:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-06 16:33:27 +0100
commit8965d348ad07c326c8e17e3137c151bcc98b0a53 (patch)
tree04153981ff85318dc655cab045df2ac16a38040f /net-libs
parent398c033d3c836f59a4f2668f3c27b680b7ed1f54 (diff)
gentoo auto-resync : 06:09:2022 - 16:33:27
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/Manifest.gzbin32618 -> 32620 bytes
-rw-r--r--net-libs/neon/Manifest2
-rw-r--r--net-libs/neon/neon-0.32.3.ebuild107
3 files changed, 109 insertions, 0 deletions
diff --git a/net-libs/Manifest.gz b/net-libs/Manifest.gz
index bf2de4d9caf3..8ef07399150e 100644
--- a/net-libs/Manifest.gz
+++ b/net-libs/Manifest.gz
Binary files differ
diff --git a/net-libs/neon/Manifest b/net-libs/neon/Manifest
index ddd0a4a481bb..0472b2265409 100644
--- a/net-libs/neon/Manifest
+++ b/net-libs/neon/Manifest
@@ -1,3 +1,5 @@
DIST neon-0.32.2.tar.gz 880651 BLAKE2B 3629eee38e10ada5e001bf0afb77c70814083bf553596fc150a6cf21f0b66cf4de28841b242f68faaeb44fa5e0ad260939102b015d2a543ef59012876256b364 SHA512 2580a3c8c3cf4aff2d399f72a721ccfb4e68434ef92da4af8103c126812d779b9fbe5cafbab512c79f4365bbb3d3eac61568748136470e86f7aa7b98b27053c8
+DIST neon-0.32.3.tar.gz 884939 BLAKE2B e0f0b242bb65f595d2e357c08a770faf503c70df69caf200b62bb50a90ae34360854d051d2b46900f18c1f46d9570bec9302e1f27837efcb859f7197f810ff26 SHA512 8dec5cbc823e38506725529c9e8fad95c93145d9e5d54131f8ceca6bbfe1b64f7f0eb1ce117072ea2f28edc67fa2f5a7f53bcc08ee644010fea76403ab6bbaad
EBUILD neon-0.32.2.ebuild 2552 BLAKE2B fdc25d5f99bea28be7c53ade0b924efe828870aef50e2cbba0e8ec1ec600229562b05eb5202ecc5404870f3e0cf0b4c2c5aaba33c796d698420bd73623105989 SHA512 d97517e44395855766923f37aa5268636159198cfcbb6b59467f7a19c6151ea89c91198b422bdaf689d358a507de8e0535aa1b575353711a649fb1f41fccfdf4
+EBUILD neon-0.32.3.ebuild 2559 BLAKE2B 33cff64bd9cc878232e6e1a0d70d78d3816e1fa71a57484d1152c7f93773f9e028c612a8cee85ce677b3fd9c51741a5575e4053fb01e73a7466537b21210975d SHA512 0592fcb7f9cc3e40fac730c3f68afcda11c68033cd98d1aa47c2e92d666707b392b19375b27f595df0bbee44a0cd28ea693c49ae53ffebf676065de6d111a26b
MISC metadata.xml 1465 BLAKE2B cc9629974affeda497ea2825a4412182f9445f90ef04eb1337a456fad1b578a30d6b1135255b278cf795ffa9be7d78e810797fc7fd170606e52e48f7af5e02fc SHA512 ca250ba34c8c50c20d92a60b138e6548920f9fead9c5dda3a18928bd06203f6952c4a6a2a0eee846c3f7bcd48c79959c92af9a0fd1a5133273fdc09fcbb051f3
diff --git a/net-libs/neon/neon-0.32.3.ebuild b/net-libs/neon/neon-0.32.3.ebuild
new file mode 100644
index 000000000000..7a2c2983e572
--- /dev/null
+++ b/net-libs/neon/neon-0.32.3.ebuild
@@ -0,0 +1,107 @@
+# Copyright 2001-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit autotools libtool multilib-minimal
+
+DESCRIPTION="HTTP and WebDAV client library"
+HOMEPAGE="https://notroj.github.io/neon/ https://github.com/notroj/neon"
+SRC_URI="https://notroj.github.io/neon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/27"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc +expat gnutls kerberos libproxy nls pkcs11 ssl test zlib"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig
+ test? (
+ ssl? (
+ dev-libs/openssl:0
+ pkcs11? ( dev-libs/nss )
+ )
+ )"
+DEPEND="expat? ( dev-libs/expat:0=[${MULTILIB_USEDEP}] )
+ !expat? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
+ kerberos? ( virtual/krb5:0=[${MULTILIB_USEDEP}] )
+ libproxy? ( net-libs/libproxy:0=[${MULTILIB_USEDEP}] )
+ nls? ( virtual/libintl:0=[${MULTILIB_USEDEP}] )
+ ssl? (
+ gnutls? (
+ app-misc/ca-certificates
+ net-libs/gnutls:0=[${MULTILIB_USEDEP}]
+ )
+ !gnutls? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ pkcs11? ( dev-libs/pakchois:0=[${MULTILIB_USEDEP}] )
+ )
+ zlib? ( sys-libs/zlib:0=[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/neon-config
+)
+
+DOCS=( AUTHORS BUGS NEWS README.md THANKS TODO )
+
+src_prepare() {
+ if use gnutls; then
+ # Ignore failure of test pkcs11.
+ # https://github.com/notroj/neon/issues/72
+ sed -e "s/T(pkcs11)/T_XFAIL(pkcs11)/" -i test/ssl.c || die
+ fi
+
+ eapply_user
+
+ AT_M4DIR="macros" eautoreconf
+
+ elibtoolize
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=()
+
+ if has_version sys-libs/glibc; then
+ einfo "Enabling SSL library thread-safety using POSIX threads..."
+ myconf+=(--enable-threadsafe-ssl=posix)
+ fi
+
+ if use expat; then
+ myconf+=(--with-expat)
+ else
+ myconf+=(--with-libxml2)
+ fi
+
+ if use ssl; then
+ if use gnutls; then
+ myconf+=(--with-ssl=gnutls --with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt")
+ else
+ myconf+=(--with-ssl=openssl)
+ fi
+ fi
+
+ econf \
+ --enable-shared \
+ $(use_with kerberos gssapi) \
+ $(use_with libproxy) \
+ $(use_enable nls) \
+ $(use_with pkcs11 pakchois) \
+ $(use_with zlib) \
+ "${myconf[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install-{config,headers,lib,man,nls}
+
+ if multilib_is_native_abi && use doc; then
+ dodoc -r doc/html
+ fi
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name "*.la" -delete || die
+
+ einstalldocs
+}