summaryrefslogtreecommitdiff
path: root/net-libs/xrootd-ceph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /net-libs/xrootd-ceph
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'net-libs/xrootd-ceph')
-rw-r--r--net-libs/xrootd-ceph/Manifest3
-rw-r--r--net-libs/xrootd-ceph/metadata.xml13
-rw-r--r--net-libs/xrootd-ceph/xrootd-ceph-4.12.0.ebuild24
3 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/xrootd-ceph/Manifest b/net-libs/xrootd-ceph/Manifest
new file mode 100644
index 000000000000..8c9bf316d52b
--- /dev/null
+++ b/net-libs/xrootd-ceph/Manifest
@@ -0,0 +1,3 @@
+DIST xrootd-ceph-4.12.0.tar.gz 80601 BLAKE2B 05e31ec3a03d50f36f7ef368705ca8ad064d1d9da4fc3815aaf96ce358da07348aaea264d82884da2782cf7c1069b584269fff9f2a3140057b2d4d2929639f77 SHA512 de55cc923bad3629de6428dbc4e7c7e2cb802512f03f49bcfc79f12221828cd9702f1c9a1bc28b599dce801c937146cf381dfd589c85f4f5721c4fbf13f6ad34
+EBUILD xrootd-ceph-4.12.0.ebuild 680 BLAKE2B dffac256f61140144d51cbfc72d4c996273be0fa1f55685138d040e3acde5f46ba50b07ed601c5c06cac56c944ea1c22e506f350acbaab33e17b0a77486adc86 SHA512 9f014c81e32d0936307d9c000fb69ab7d992cb14e22a9d111ae582cfd3fa946241108d3ab915f92fdce9bfc4b7f1f8ef50130ca753f86d8f101a3407eddba5cc
+MISC metadata.xml 496 BLAKE2B e2a202798936cfc2061b2660ab7ad32a4a4c02aab9789e46bdd5981795815505da531ab2891c9022447d2154b6070ddba3e1daa68f25b2373757cbe17d960a6c SHA512 43fa4446767cb279125fdedcaf415af260c42871460fd1144aff7bf47769070da9e9c4fc0e8b32c87fdd879f8dca24586a0764f0ad8a3ba715e1d95e07d60f70
diff --git a/net-libs/xrootd-ceph/metadata.xml b/net-libs/xrootd-ceph/metadata.xml
new file mode 100644
index 000000000000..65cbb7c9f142
--- /dev/null
+++ b/net-libs/xrootd-ceph/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This XROOTD plug-in allows it to interface with rados block devices via
+ <pkg>sys-cluster/ceph</pkg>. Until its version 4.10.0 it used to part
+ of <pkg>net-libs/xrootd</pkg> itself.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-libs/xrootd-ceph/xrootd-ceph-4.12.0.ebuild b/net-libs/xrootd-ceph/xrootd-ceph-4.12.0.ebuild
new file mode 100644
index 000000000000..f701427b94c7
--- /dev/null
+++ b/net-libs/xrootd-ceph/xrootd-ceph-4.12.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="xrootd OSS plug-in for interfacing with Ceph storage platform"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+SRC_URI="https://github.com/xrootd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+
+DEPEND="net-libs/xrootd
+ !<net-libs/xrootd-4.10.0[rbd]
+ sys-cluster/ceph"
+RDEPEND="${DEPEND}"
+
+# xrootd plugins are not intended to be linked with,
+# they are to be loaded at runtime by xrootd,
+# see https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-$(ver_cut 1).so"