summaryrefslogtreecommitdiff
path: root/net-libs/wslay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-16 02:29:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-16 02:29:20 +0100
commit7896e968620f545121daeea31881814ccc8d4f47 (patch)
tree537e4de8b13e1b2add5e11c9ecf4c7abf68a0a94 /net-libs/wslay
parent7255c5d5fcd8fcdd07d2791563dc43bf4e14cf3a (diff)
gentoo auto-resync : 16:08:2022 - 02:29:20
Diffstat (limited to 'net-libs/wslay')
-rw-r--r--net-libs/wslay/Manifest3
-rw-r--r--net-libs/wslay/metadata.xml11
-rw-r--r--net-libs/wslay/wslay-1.1.1_p20210115.ebuild46
3 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/wslay/Manifest b/net-libs/wslay/Manifest
new file mode 100644
index 000000000000..b113e9a2dff3
--- /dev/null
+++ b/net-libs/wslay/Manifest
@@ -0,0 +1,3 @@
+DIST wslay-1.1.1_p20210115.tar.gz 57514 BLAKE2B 1808814cf9cecc874f341989f14b36d53c9386681934f86547274dd9c926d1add84182960f02f0f2738e55723da17b99b16f046eea75ed1ec65be997d274ed21 SHA512 97fd58fba956162ebba8f824748ad3c161afb6a72e6e5db515f94a81edb99ddcd8eb332de4ffd08cb36f79010761036e4432e6d93b000ac5e4b0a88deeda9023
+EBUILD wslay-1.1.1_p20210115.ebuild 1018 BLAKE2B cbca9c6add7850c38579e46b0de923e9aca15948803785c294be6c123db8ebb2bb539e875f91653c6b0f0253ff703801c04d19938ce876848c2a0fe249f23876 SHA512 20fa96345e29e32823db8af5e810d6cbe5e227627040102e1229d23c2fe2cbe1c506451489db01ce03b372954e5dafc4e76b4dcd1eacdf6e927d5b56cdc13bcb
+MISC metadata.xml 328 BLAKE2B fdf72cb52db036f22c8ec9a01e2dda72d44fa581ddf6c264ac4450622af76f607d21f4b1c72462bc911f66df98c2102815c1b6495d60b4fc42961d2b786db4ce SHA512 4a1b27580578d37cac7840da1ffe72a23def0b6769acb2afa5b45691898b68c3150842cfc21d35ffff7effe93f36528819ca5f6247617a6e0c18ddeeaa934223
diff --git a/net-libs/wslay/metadata.xml b/net-libs/wslay/metadata.xml
new file mode 100644
index 000000000000..47029d119abf
--- /dev/null
+++ b/net-libs/wslay/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ionen@gentoo.org</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tatsuhiro-t/wslay</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-libs/wslay/wslay-1.1.1_p20210115.ebuild b/net-libs/wslay/wslay-1.1.1_p20210115.ebuild
new file mode 100644
index 000000000000..4ddb9775de62
--- /dev/null
+++ b/net-libs/wslay/wslay-1.1.1_p20210115.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+WSLAY_HASH="45d22583b488f79d5a4e598cc7675c191c5ab53f"
+
+DESCRIPTION="WebSocket library in C"
+HOMEPAGE="https://tatsuhiro-t.github.io/wslay/"
+SRC_URI="https://github.com/tatsuhiro-t/wslay/archive/${WSLAY_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${WSLAY_HASH}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-util/cunit )"
+BDEPEND="doc? ( dev-python/sphinx )"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ # no options... and cmake build has different issues
+ $(usev !doc ac_cv_path_SPHINX_BUILD=)
+ $(usev !test ac_cv_lib_cunit_CU_initialize_registry=)
+ PKG_CONFIG=false # disables examples by failing to find nettle
+ )
+
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ local DOCS=( AUTHORS NEWS README.rst ) # skip non-rst README
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}