summaryrefslogtreecommitdiff
path: root/net-libs/wandio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /net-libs/wandio
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'net-libs/wandio')
-rw-r--r--net-libs/wandio/Manifest2
-rw-r--r--net-libs/wandio/files/wandio-4.2.3_p1-fix-lz4-check.patch12
-rw-r--r--net-libs/wandio/wandio-4.2.3_p1-r2.ebuild65
3 files changed, 79 insertions, 0 deletions
diff --git a/net-libs/wandio/Manifest b/net-libs/wandio/Manifest
index 885d1cbf0eb1..617a5d1fb085 100644
--- a/net-libs/wandio/Manifest
+++ b/net-libs/wandio/Manifest
@@ -1,3 +1,5 @@
+AUX wandio-4.2.3_p1-fix-lz4-check.patch 418 BLAKE2B a728dc17df93a161d2bca3fe964f18a7aad073028794ce06a6dd316d60eec529e392e5c2d7e5e66ab3b6100d4f962b66cb21acb782bde49c3b35707b3909b2ef SHA512 ef8b4c659975a4562e720dfd6b2ad1ddb51086778b0f9100516e442df24cc4d45bfe413727d88619453f4972e8e60ce83fd126cb9f8eb5c5ab21364e51686606
DIST wandio-4.2.3_p1.tar.gz 15418423 BLAKE2B 1274f10b87964e2dc87ed25a465991b1e4e9211b75fb5ac5a13a0aa535ff30ddfa69059b3d41de7dc758220bda8dd9d02ca7ed31b7c0ca2997641968cc729e48 SHA512 b4bfff9d33010c04826318c560592ee7f7aba9fccd0eba0f29c6294a636971bf4ac5105ffb9addfc22946e7b7234396dafa6c7e0a0d8de3ee1b7e586c069b438
EBUILD wandio-4.2.3_p1-r1.ebuild 1075 BLAKE2B c2b0086b33f6e43826cfba1520bbae67b5b67dc34fb46c2e2d9c08d883d5365d74eea3e113a528bed9285885a97c366f13a624699a45c1c3fdf45fa5e2fa8cd5 SHA512 b3d777a31fab7bf88b76e8823fdaa3771cfd2387119421752ce0d12d0d6f9e6fb0fe99e45628372efde653f2bde962479e2b4f89d33657d547ee264b63a8d651
+EBUILD wandio-4.2.3_p1-r2.ebuild 1216 BLAKE2B 59373a72385eaba7bbc432cea4ed23243e85080fc8b50a3adbe590f01ed50158bbce6545c06b0aa69175f9c57b2b8b546a9366d4268fbcdf52f69ccc972f344b SHA512 cc87484f8b3e523a1b24f72e36ff77d0f23ad26bc5ce3f67ceb18b1a33b4cf2a5458004a74fe51f299429a9c940954878005dc1fcf34f1108feee75044a29a54
MISC metadata.xml 413 BLAKE2B 928bdd9e84f02a894ce36b6db96f7b842736f79f77b9152f98af110c9b8f2fca60ae45e0860ed7e3fc6c035c469fc0baf1c115a96d776d1d8df5e645626a952c SHA512 27b9579f785dcf1717c606e771b9e492889a6d97b0be2904a505adb83460e8ceb322d9432fa3a72d2bf2232a9eacb528807cb4eec4b20f1ab68c85b0007b1523
diff --git a/net-libs/wandio/files/wandio-4.2.3_p1-fix-lz4-check.patch b/net-libs/wandio/files/wandio-4.2.3_p1-fix-lz4-check.patch
new file mode 100644
index 000000000000..db50cf1c0c04
--- /dev/null
+++ b/net-libs/wandio/files/wandio-4.2.3_p1-fix-lz4-check.patch
@@ -0,0 +1,12 @@
+https://github.com/wanduow/wandio/pull/51
+--- a/configure.ac
++++ b/configure.ac
+@@ -260,7 +260,7 @@ AC_ARG_WITH([lz4],
+ AS_IF([test "x$with_lz4" != "xno"],
+ [
+ AC_CHECK_LIB(lz4, LZ4F_createDecompressionContext, have_lz4f=yes, have_lz4f=no)
+- ], [have_zstd=no])
++ ], [have_lz4f=no])
+
+ AS_IF([test "x$have_lz4f" = "xyes"], [
+ if test "$ac_cv_lib_lz4_code" != "none required"; then
diff --git a/net-libs/wandio/wandio-4.2.3_p1-r2.ebuild b/net-libs/wandio/wandio-4.2.3_p1-r2.ebuild
new file mode 100644
index 000000000000..d927232b4f66
--- /dev/null
+++ b/net-libs/wandio/wandio-4.2.3_p1-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C library for simple and efficient file IO"
+HOMEPAGE="https://research.wand.net.nz/software/libwandio.php"
+SRC_URI="https://github.com/wanduow/${PN}/archive/${PV/_p/-}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_p/-}"
+
+LICENSE="LGPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 http lzma lzo lz4 test zlib zstd"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( lzma lzo )"
+
+RDEPEND="
+ !<net-libs/libtrace-4
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ lz4? ( app-arch/lz4:= )
+ http? ( net-misc/curl )
+ zlib? ( sys-libs/zlib )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( app-arch/lzop )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2.3_p1-fix-lz4-check.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with bzip2) \
+ $(use_with http) \
+ $(use_with lzma) \
+ $(use_with lzo) \
+ $(use_with lz4) \
+ $(use_with zlib) \
+ $(use_with zstd)
+}
+
+src_test() {
+ pushd test || die
+ "${BROOT}"/bin/bash do-basic-tests.sh || die
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}