summaryrefslogtreecommitdiff
path: root/net-libs/wandio/wandio-4.2.3_p1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /net-libs/wandio/wandio-4.2.3_p1-r1.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'net-libs/wandio/wandio-4.2.3_p1-r1.ebuild')
-rw-r--r--net-libs/wandio/wandio-4.2.3_p1-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-libs/wandio/wandio-4.2.3_p1-r1.ebuild b/net-libs/wandio/wandio-4.2.3_p1-r1.ebuild
new file mode 100644
index 000000000000..e0d614fcb241
--- /dev/null
+++ b/net-libs/wandio/wandio-4.2.3_p1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="C library for simple and efficient file IO"
+HOMEPAGE="https://research.wand.net.nz/software/libwandio.php"
+SRC_URI="https://github.com/wanduow/${PN}/archive/${PV/_p/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 http lzma lzo static-libs test zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !<net-libs/libtrace-4
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ http? ( net-misc/curl )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( app-arch/lzop )
+"
+S=${WORKDIR}/${P/_p/-}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with bzip2) \
+ $(use_with http) \
+ $(use_with lzma) \
+ $(use_with lzo) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+src_test() {
+ pushd test || die
+ sh do-basic-tests.sh
+}