summaryrefslogtreecommitdiff
path: root/net-libs/wandio/wandio-4.2.3_p1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /net-libs/wandio/wandio-4.2.3_p1-r1.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'net-libs/wandio/wandio-4.2.3_p1-r1.ebuild')
-rw-r--r--net-libs/wandio/wandio-4.2.3_p1-r1.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/net-libs/wandio/wandio-4.2.3_p1-r1.ebuild b/net-libs/wandio/wandio-4.2.3_p1-r1.ebuild
index e0d614fcb241..4eef4248a4d6 100644
--- a/net-libs/wandio/wandio-4.2.3_p1-r1.ebuild
+++ b/net-libs/wandio/wandio-4.2.3_p1-r1.ebuild
@@ -1,18 +1,21 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools
DESCRIPTION="C library for simple and efficient file IO"
HOMEPAGE="https://research.wand.net.nz/software/libwandio.php"
SRC_URI="https://github.com/wanduow/${PN}/archive/${PV/_p/-}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_p/-}"
LICENSE="LGPL-3"
SLOT="0/6"
KEYWORDS="~amd64 ~x86"
-IUSE="bzip2 http lzma lzo static-libs test zlib"
+IUSE="bzip2 http lzma lzo test zlib"
RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( lzma lzo )"
RDEPEND="
!<net-libs/libtrace-4
@@ -26,7 +29,6 @@ DEPEND="
${RDEPEND}
test? ( app-arch/lzop )
"
-S=${WORKDIR}/${P/_p/-}
src_prepare() {
default
@@ -35,7 +37,7 @@ src_prepare() {
src_configure() {
econf \
- $(use_enable static-libs static) \
+ --disable-static \
$(use_with bzip2) \
$(use_with http) \
$(use_with lzma) \
@@ -43,12 +45,12 @@ src_configure() {
$(use_with zlib)
}
+src_test() {
+ pushd test || die
+ ${CONFIG_SHELL}/bin/bash do-basic-tests.sh || die
+}
+
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}
-
-src_test() {
- pushd test || die
- sh do-basic-tests.sh
-}