summaryrefslogtreecommitdiff
path: root/net-libs/uhttpmock/uhttpmock-0.5.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /net-libs/uhttpmock/uhttpmock-0.5.3.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'net-libs/uhttpmock/uhttpmock-0.5.3.ebuild')
-rw-r--r--net-libs/uhttpmock/uhttpmock-0.5.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/uhttpmock/uhttpmock-0.5.3.ebuild b/net-libs/uhttpmock/uhttpmock-0.5.3.ebuild
new file mode 100644
index 000000000000..d8184154dea5
--- /dev/null
+++ b/net-libs/uhttpmock/uhttpmock-0.5.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="HTTP web service mocking library"
+HOMEPAGE="https://gitlab.com/uhttpmock/uhttpmock"
+SRC_URI="http://tecnocode.co.uk/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="debug +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ >=net-libs/libsoup-2.37.91:2.4
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+"
+BDEPEND="
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}