summaryrefslogtreecommitdiff
path: root/net-libs/udns
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-09 04:23:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-09 04:23:59 +0100
commit49307b439ea0ae14beb0772de83e70297ae8356c (patch)
tree02f22afc29810c4558bf87d13c56f288d43fecc3 /net-libs/udns
parent99b2c44c1425c7b2925846d4c44b2bf2f78dc786 (diff)
gentoo auto-resync : 09:07:2023 - 04:23:59
Diffstat (limited to 'net-libs/udns')
-rw-r--r--net-libs/udns/Manifest3
-rw-r--r--net-libs/udns/files/udns-0.4-configure-pton-ntop-clang16.patch22
-rw-r--r--net-libs/udns/udns-0.4-r2.ebuild (renamed from net-libs/udns/udns-0.4-r1.ebuild)3
3 files changed, 26 insertions, 2 deletions
diff --git a/net-libs/udns/Manifest b/net-libs/udns/Manifest
index 2fde62b15191..9f8f288147c4 100644
--- a/net-libs/udns/Manifest
+++ b/net-libs/udns/Manifest
@@ -1,4 +1,5 @@
AUX udns-0.4-configure-clang16.patch 662 BLAKE2B 1f5fd83da10302849a3cb519ca49d07d88c4c08635baa1d15712fb4606430150c3e21d1da187b0bb1b28ed0fe50ece3d0b4f0a788214a843e0783ccb0e2140b6 SHA512 8265fe9385598973f6decb68c6d2650704d800007476e5a8ad761a1938a04b6e43b0405cd674add1e9d5f5f68691bc36d5a99a370049d258f194805009f4235d
+AUX udns-0.4-configure-pton-ntop-clang16.patch 523 BLAKE2B f7050249692662d465beb39e6c5be9abb35985832f88ec45c803757a3514f850b2ab9442b1a68d2708b37607e96fbde94fa2b95f83ee3898ef77ce4905d41511 SHA512 b9138f923b309521e7349ba4448f3064682284eeffa1061d2e5c01a13c5ab42d14415121e0e6814c6074aae8c294c61e0c64e4656e87f9bdbe0720317b548365
DIST udns-0.4.tar.gz 84716 BLAKE2B df41b325ae2ffaaaf09e1bb6f52d9e9a7c468c70d8bec849cb90ebcb1fac773ee2dc7e37125a75750b61a1a78d0416e6c9aeb72e43780b474d36e370a1b9cd8d SHA512 2990d57b3b6bf176a12ee07fd4391921e13634fc8409e8ce4df8dbe7b3556a116ae59ab328a1b6a95ebc94298f6b56ec7197a06a649d8d642b371b8ecef3e40b
-EBUILD udns-0.4-r1.ebuild 939 BLAKE2B 12d94ad9fb0b3f3fade0814bdb30c7db2921c8703e78bd1642d0ac80b9985db863260f1e2d08733c46987dac8ae464e82ad5c77c459560ef51990a1f8aec3cf1 SHA512 3005ee191678550d9a2b7b1615a2849d87a201652cda304be7974ea726091e9919192e41aca0e5d3736ba9517cb4a7250a897431396bc760e6bdede6efa71a6b
+EBUILD udns-0.4-r2.ebuild 998 BLAKE2B c46346e2c40791a96775a01d1c27780d089feb0944d4bdeefcddd81deff44a1465933f13f016f4b37c1bb2483a63f0327036bcae0d5c2616a6d7ed6d59485cf1 SHA512 142aab4b1c69f024448bc42429e476457a4a153e329bb9004b2bfb88c77176833bf8be438a4b4e7000085bdd2019c48000b42cb64ccc428ddd924ff0bcdde8a0
MISC metadata.xml 410 BLAKE2B 1e21502a7b8c033b1a659a3cd235069d51a50531ed37c2873f610df9131723764971b3886f59ba4c212685db3fef6a8df17681942f011bd905ff4d07c83a7c49 SHA512 073730684153f02c08348567177e5e048ab93441ea3429ff40f15e32ee555e7a30476c19566b55cf86da835fcd479cc7f408bc95ef371d66cb4e7e8408b5cc04
diff --git a/net-libs/udns/files/udns-0.4-configure-pton-ntop-clang16.patch b/net-libs/udns/files/udns-0.4-configure-pton-ntop-clang16.patch
new file mode 100644
index 000000000000..5eb0010092a8
--- /dev/null
+++ b/net-libs/udns/files/udns-0.4-configure-pton-ntop-clang16.patch
@@ -0,0 +1,22 @@
+Bug: https://bugs.gentoo.org/883285
+
+From e39b749619191226ccbf8730084c0d2dcadc9065 Mon Sep 17 00:00:00 2001
+From: Violet Purcell <vimproved@inventati.org>
+Date: Sat, 8 Jul 2023 18:34:11 +0000
+Subject: [PATCH] Fix detection of dns_pton and dns_ntop with clang 16
+
+--- a/configure
++++ b/configure
+@@ -94,7 +94,8 @@ int main() {
+ char buf[64];
+ long x = 0;
+ inet_pton(AF_INET, &x, buf);
+- return inet_ntop(AF_INET, &x, buf, sizeof(buf));
++ inet_ntop(AF_INET, &x, buf, sizeof(buf));
++ return 0;
+ }
+ EOF
+
+--
+2.41.0
+
diff --git a/net-libs/udns/udns-0.4-r1.ebuild b/net-libs/udns/udns-0.4-r2.ebuild
index f8f8c3675854..a963d2ac18b4 100644
--- a/net-libs/udns/udns-0.4-r1.ebuild
+++ b/net-libs/udns/udns-0.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,6 +16,7 @@ IUSE="ipv6 static +tools"
PATCHES=(
"${FILESDIR}"/${PN}-0.4-configure-clang16.patch
+ "${FILESDIR}"/${PN}-0.4-configure-pton-ntop-clang16.patch
)
src_configure() {