summaryrefslogtreecommitdiff
path: root/net-libs/udns/udns-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /net-libs/udns/udns-0.4.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'net-libs/udns/udns-0.4.ebuild')
-rw-r--r--net-libs/udns/udns-0.4.ebuild26
1 files changed, 8 insertions, 18 deletions
diff --git a/net-libs/udns/udns-0.4.ebuild b/net-libs/udns/udns-0.4.ebuild
index f19b2595dc0b..0953628925ed 100644
--- a/net-libs/udns/udns-0.4.ebuild
+++ b/net-libs/udns/udns-0.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit eutils multilib toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Async-capable DNS stub resolver library"
HOMEPAGE="http://www.corpit.ru/mjt/udns.html"
@@ -14,26 +14,18 @@ SLOT="0"
KEYWORDS="amd64 ~hppa ppc ~ppc64 sparc x86"
IUSE="ipv6 static +tools"
-# Yes, this doesn't depend on any other library beside "system" set
-DEPEND=""
-RDEPEND=""
-
src_configure() {
# Uses non-standard configure script, econf doesn't work
CC=$(tc-getCC) ./configure $(use_enable ipv6) || die "Configure failed"
}
src_compile() {
- if use tools; then
- emake shared
- else
- emake sharedlib
- fi
+ emake $(usex tools shared sharedlib)
}
src_install() {
dolib.so libudns.so.0
- dosym libudns.so.0 "/usr/$(get_libdir)/libudns.so"
+ dosym libudns.so.0 /usr/$(get_libdir)/libudns.so
if use tools; then
newbin dnsget_s dnsget
@@ -41,12 +33,10 @@ src_install() {
newbin rblcheck_s rblcheck
fi
- insinto /usr/include
- doins udns.h
+ doheader udns.h
doman udns.3
- if use tools; then
- doman dnsget.1 rblcheck.1
- fi
+ use tools && doman dnsget.1 rblcheck.1
+
dodoc NEWS NOTES TODO
}