summaryrefslogtreecommitdiff
path: root/net-libs/tox/tox-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /net-libs/tox/tox-9999.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'net-libs/tox/tox-9999.ebuild')
-rw-r--r--net-libs/tox/tox-9999.ebuild46
1 files changed, 20 insertions, 26 deletions
diff --git a/net-libs/tox/tox-9999.ebuild b/net-libs/tox/tox-9999.ebuild
index e7b2b5569ca2..6480c17e2cc6 100644
--- a/net-libs/tox/tox-9999.ebuild
+++ b/net-libs/tox/tox-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools git-r3 user systemd
+inherit cmake-utils git-r3 systemd user
DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
HOMEPAGE="https://tox.chat"
@@ -11,43 +11,37 @@ SRC_URI=""
EGIT_REPO_URI="https://github.com/TokTok/c-toxcore.git"
LICENSE="GPL-3+"
-SLOT="0/0.1"
+SLOT="0/0.2"
KEYWORDS=""
-IUSE="+av daemon log-debug log-error log-info log-trace log-warn +no-log ntox static-libs test"
+IUSE="+av daemon log-debug log-trace +no-log static-libs test"
-REQUIRED_USE="^^ ( no-log log-trace log-debug log-info log-warn log-error )"
+REQUIRED_USE="^^ ( no-log log-trace log-debug )"
RDEPEND="
av? ( media-libs/libvpx:=
media-libs/opus )
daemon? ( dev-libs/libconfig )
- ntox? ( sys-libs/ncurses:0= )
>=dev-libs/libsodium-0.6.1:=[asm,urandom]"
DEPEND="${RDEPEND}
- test? ( dev-libs/check )
virtual/pkgconfig"
-src_prepare() {
- default
- eautoreconf
-}
-
src_configure() {
- econf \
- $(usex log-trace "--enable-logging --with-log-level=TRACE" "") \
- $(usex log-debug "--enable-logging --with-log-level=DEBUG" "") \
- $(usex log-info "--enable-logging --with-log-level=INFO" "") \
- $(usex log-warn "--enable-logging --with-log-level=WARNING" "") \
- $(usex log-error "--enable-logging --with-log-level=ERROR" "") \
- $(use_enable av) \
- $(use_enable test tests) \
- $(use_enable ntox) \
- $(use_enable daemon) \
- $(use_enable static-libs static)
+ local mycmakeargs=(
+ -DTRACE=$(usex log-trace)
+ -DDEBUG=$(usex log-debug)
+ -DBUILD_TOXAV=$(usex av)
+ -DMUST_BUILD_TOXAV=$(usex av)
+ -DBUILD_AV_TEST=$(usex av)
+ -DBOOTSTRAP_DAEMON=$(usex daemon)
+ -DENABLE_STATIC=$(usex static-libs)
+ )
+
+ cmake-utils_src_configure
}
src_install() {
- default
+ cmake-utils_src_install
+
if use daemon; then
newinitd "${FILESDIR}"/initd tox-dht-daemon
newconfd "${FILESDIR}"/confd tox-dht-daemon
@@ -61,8 +55,8 @@ src_install() {
pkg_postinst() {
if use daemon; then
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
+ enewgroup tox
+ enewuser tox -1 -1 -1 tox
if [[ -f ${EROOT%/}/var/lib/tox-dht-bootstrap/key ]]; then
ewarn "Backwards compatability with the bootstrap daemon might have been"
ewarn "broken a while ago. To resolve this issue, REMOVE the following files:"