summaryrefslogtreecommitdiff
path: root/net-libs/tox/tox-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-libs/tox/tox-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-libs/tox/tox-9999.ebuild')
-rw-r--r--net-libs/tox/tox-9999.ebuild33
1 files changed, 20 insertions, 13 deletions
diff --git a/net-libs/tox/tox-9999.ebuild b/net-libs/tox/tox-9999.ebuild
index ba31cc1a5c28..ae60fff26c54 100644
--- a/net-libs/tox/tox-9999.ebuild
+++ b/net-libs/tox/tox-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ EGIT_REPO_URI="https://github.com/TokTok/c-toxcore.git"
LICENSE="GPL-3+"
SLOT="0/0.2"
KEYWORDS=""
-IUSE="+av daemon dht-node ipv6 log-debug +log-error log-info log-trace log-warn test"
+IUSE="+av debug daemon dht-node ipv6 key-utils log-debug +log-error log-info log-trace log-warn test"
RESTRICT="!test? ( test )"
REQUIRED_USE="?? ( log-debug log-error log-info log-trace log-warn )
@@ -21,6 +21,7 @@ REQUIRED_USE="?? ( log-debug log-error log-info log-trace log-warn )
BDEPEND="virtual/pkgconfig"
DEPEND="dev-libs/libsodium:=[asm,urandom,-minimal]
+ dev-libs/msgpack
av? (
media-libs/libvpx:=
media-libs/opus
@@ -31,14 +32,15 @@ RDEPEND="
daemon? (
acct-group/tox
acct-user/tox
- )"
+ )
+ key-utils? ( || ( sys-devel/gcc[openmp] sys-devel/clang-runtime[openmp] ) )"
src_prepare() {
cmake_src_prepare
#remove faulty tests
- for testname in lan_discovery save_compatibility set_status_message; do
- sed -i -e "/^auto_test(${testname})$/d" CMakeLists.txt || die
+ for testname in lan_discovery save_load; do
+ sed -i -e "/^auto_test(${testname})$/d" ./auto_tests/CMakeLists.txt || die
done
}
@@ -46,15 +48,19 @@ src_configure() {
local mycmakeargs=(
-DAUTOTEST=$(usex test ON OFF)
-DBOOTSTRAP_DAEMON=$(usex daemon ON OFF)
+ -DBUILD_FUN_UTILS=$(usex key-utils ON OFF)
+ -DBUILD_FUZZ_TESTS=OFF #Upstream reports that this breaks all other tests
-DBUILD_MISC_TESTS=$(usex test ON OFF)
-DBUILD_TOXAV=$(usex av ON OFF)
+ -DCMAKE_BUILD_TYPE=$(usex debug Debug Release)
-DDHT_BOOTSTRAP=$(usex dht-node ON OFF)
-DENABLE_SHARED=ON
-DENABLE_STATIC=OFF
-DMUST_BUILD_TOXAV=$(usex av ON OFF))
if use test; then
mycmakeargs+=(
- -DTEST_TIMEOUT_SECONDS=120
+ -DTEST_TIMEOUT_SECONDS=150
+ -DNON_HERMETIC_TESTS=OFF
-DUSE_IPV6=$(usex ipv6 ON OFF))
else
mycmakeargs+=(-DUSE_IPV6=OFF)
@@ -95,12 +101,13 @@ src_install() {
pkg_postinst() {
if use dht-node; then
- ewarn "There is currently an unresolved issuer with tox DHT"
- ewarn "Bootstrap node that causes the program to be built"
- ewarn "with a null libray reference. This causes an infinite"
- ewarn "loop for certain revdep-rebuild commands. If you aren't"
- ewarn "running a node, please consider disabling the dht node"
- ewarn "use flag. For more information please refer to"
- ewarn "https://github.com/toktok/c-toxcore/issues/1144"
+ ewarn "The QA notice regarding libmisc_tools.so is known by the upstream"
+ ewarn "developers and is on their TODO list. For more information,"
+ ewarn "please see 'https://github.com/toktok/c-toxcore/issues/1144'"
+ ewarn ""
+ ewarn "There is currently an unresolved issuer with tox DHT Bootstrap node"
+ ewarn "that causes the program to be built with a null libray reference."
+ ewarn "This causes an infinite loop for certain revdep-rebuild commands."
+ ewarn "If you aren't running a node, consider disabling the dht node use flag"
fi
}