summaryrefslogtreecommitdiff
path: root/net-libs/telepathy-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /net-libs/telepathy-qt
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'net-libs/telepathy-qt')
-rw-r--r--net-libs/telepathy-qt/Manifest4
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild5
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-9999.ebuild10
3 files changed, 10 insertions, 9 deletions
diff --git a/net-libs/telepathy-qt/Manifest b/net-libs/telepathy-qt/Manifest
index dcb3bbb8f601..fb1daf41d10c 100644
--- a/net-libs/telepathy-qt/Manifest
+++ b/net-libs/telepathy-qt/Manifest
@@ -1,4 +1,4 @@
DIST telepathy-qt-0.9.8.tar.gz 6448686 BLAKE2B 7554b812c35a09aabc0ff92fea43f633b5c2f87784c8e7b387545b31c1c92eb02f9e416930c635202fe0205c4e26c1fd63c3b4a668cf0ceeb602d8a777891cd9 SHA512 fad662c02417c8e4e239d438ea3549226e589442aea8418c8922a6b78ff88422a36c1cc0d2e3591240fac115390a7fbdb1b4deea98187051cc811175b60b9e8b
-EBUILD telepathy-qt-0.9.8.ebuild 1464 BLAKE2B a6ceb45fd0549a6c27be49421d7b1e21d09b92022f5141a5cc2d4b139bafff8a29b38b3d8264bccdecee0f01322141ac90caef22c376f91e9e6c6c6f741d5bcb SHA512 4e9feaae5a2827ff27cf4604ad98ba4f273973c7e0da9cb2c697ecf49294cefce305d56aa95c6f960021da9ffd85bdbaf677abfc661403e54b28241cfda2d996
-EBUILD telepathy-qt-9999.ebuild 1607 BLAKE2B 45c28da9a88a5289302901f8fbca6ac04b370c6c09e386bafa0d0a732ad148fa330f4296302c7c2ed8cd56ba73f121e54f5ae5e848a4389d2215839b04ce696b SHA512 c46bf6f4586c45c688c6ebeaba735a5b1e69df54264f08daba5ab2f9c1b92948a841bb86d47899eaa5549c9b892b7748136c775e2a478e456b234c0e5de5dad0
+EBUILD telepathy-qt-0.9.8.ebuild 1467 BLAKE2B bec28b1b700900200632854620eba4948b546472eac720af3a2f72e7051dfcb77a298be6d40289992c878978dbdb95d7978945de1888cfcba426cd78032e4f56 SHA512 42effa89fbc610d03646549005151324f61f3b632e62924a080fef3f8b00c35114fe847affe4870bc374c327bc4b54393271ebc73c0073b926427e83edd33479
+EBUILD telepathy-qt-9999.ebuild 1595 BLAKE2B fba8fae8f79b5f74704dca13130427fa81b039257bbc369e2aa43972bb8fb508b0163e9a9747e76a5bb8bec72322e962489270e25b87e49ba3e7f2d64572bfe7 SHA512 389a5a74c5064b95018f6d1f0353b759748099d01daaf01c1f7b4335f0b086ef7960a39a5514aca6a7d18f007af557ba8c73df780e2103cbebb904426672b7d4
MISC metadata.xml 691 BLAKE2B 6539a5f9248a6f49fe13ba408b6c04a54f212c684e0dae59cbc6b510e4ddb0440dd74f9afa0540308f1c1239fcf044531d8a088b7cb98da39896a54e6c82b848 SHA512 9fd71fef229868f3b0495ad64e5845420258b92f4773da7a74e45d3c5f0d23ae738cb219bb5050c68223950652f32ed6e31ccd580f732ebc26700cda64b44891
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild
index 12ca100f7091..021e7a634ee6 100644
--- a/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.8.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit python-any-r1 cmake virtualx
DESCRIPTION="Qt bindings for the Telepathy D-Bus protocol"
@@ -17,6 +17,8 @@ IUSE="debug farstream test"
REQUIRED_USE="test? ( farstream )"
+RESTRICT="!test? ( test )"
+
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -43,7 +45,6 @@ BDEPEND="${PYTHON_DEPS}
')
)
"
-RESTRICT="!test? ( test )"
python_check_deps() {
use test || return 0
diff --git a/net-libs/telepathy-qt/telepathy-qt-9999.ebuild b/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
index 84ab23609aac..6b31f2462dc0 100644
--- a/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,11 +6,11 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI=( "https://gitlab.freedesktop.org/telepathy/${PN}" )
- inherit git-r3
+ EGIT_REPO_URI=( "https://gitlab.freedesktop.org/telepathy/${PN}" )
+ inherit git-r3
else
- SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
inherit python-any-r1 cmake virtualx