summaryrefslogtreecommitdiff
path: root/net-libs/stem/stem-1.8.0_p20211118.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /net-libs/stem/stem-1.8.0_p20211118.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'net-libs/stem/stem-1.8.0_p20211118.ebuild')
-rw-r--r--net-libs/stem/stem-1.8.0_p20211118.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/stem/stem-1.8.0_p20211118.ebuild b/net-libs/stem/stem-1.8.0_p20211118.ebuild
new file mode 100644
index 000000000000..b4a053ab34d7
--- /dev/null
+++ b/net-libs/stem/stem-1.8.0_p20211118.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python3_{7,8,9,10} pypy3)
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+COMMIT="57364fae7269ec562c5fc8cdb073ff9463d9a0f0"
+SRC_URI="https://github.com/torproject/stem/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
+ net-vpn/tor )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="net-vpn/tor"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
+
+python_prepare_all() {
+ # Disable failing test
+ sed -i -e "/test_expand_path/a \
+ \ \ \ \ return" test/integ/util/system.py || die
+ sed -i -e "/test_parsing_with_example/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_parsing_with_unknown_options/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_saving_manual/a \
+ \ \ \ \ return" test/unit/manual.py || die
+ sed -i -e "/test_sdist_matches_git/a \
+ \ \ \ \ return" test/integ/installation.py || die
+ sed -i -e "/test_connections_by_ss/a \
+ \ \ \ \ return" test/integ/util/connection.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} run_tests.py --all --target RUN_ALL || die
+}