summaryrefslogtreecommitdiff
path: root/net-libs/srt/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /net-libs/srt/files
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'net-libs/srt/files')
-rw-r--r--net-libs/srt/files/srt-1.3.1-no-rpath.patch28
-rw-r--r--net-libs/srt/files/srt-1.3.1-use-destdir-for-symlinks-09afc227e0880b12a98e18ee8182f89c3a80e3a6.patch64
2 files changed, 0 insertions, 92 deletions
diff --git a/net-libs/srt/files/srt-1.3.1-no-rpath.patch b/net-libs/srt/files/srt-1.3.1-no-rpath.patch
deleted file mode 100644
index 6e3650709c63..000000000000
--- a/net-libs/srt/files/srt-1.3.1-no-rpath.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From a90e6ab27bc20fa34536c19828db5be44be4ef4d Mon Sep 17 00:00:00 2001
-From: Craig Andrews <candrews@integralblue.com>
-Date: Mon, 26 Nov 2018 21:51:20 -0500
-Subject: [PATCH] Do not force rpath on Linux
-
----
- CMakeLists.txt | 8 --------
- 1 file changed, 8 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index eb2582c..60c4507 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -663,14 +663,6 @@ macro(srt_make_application name)
- # set (CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
- # set (FORCE_RPATH BUILD_WITH_INSTALL_RPATH TRUE INSTALL_RPATH_USE_LINK_PATH TRUE)
-
-- if (LINUX)
-- # This is only needed on Linux, on Windows (including Cygwin) the library file will
-- # be placed into the binrary directory anyway.
-- # XXX not sure about Mac.
-- # See this name used already in install(${TARGET_srt} LIBRARY DESTINATION...).
-- set(FORCE_RPATH LINK_FLAGS -Wl,-rpath,.,-rpath,../${CMAKE_INSTALL_LIBDIR} BUILD_WITH_INSTALL_RPATH TRUE INSTALL_RPATH_USE_LINK_PATH TRUE)
-- endif()
--
- # We state that Darwin always uses CLANG compiler, which honors this flag the same way.
- set_target_properties(${name} PROPERTIES COMPILE_FLAGS "${CFLAGS_CXX_STANDARD} ${EXTRA_stransmit}" ${FORCE_RPATH})
-
diff --git a/net-libs/srt/files/srt-1.3.1-use-destdir-for-symlinks-09afc227e0880b12a98e18ee8182f89c3a80e3a6.patch b/net-libs/srt/files/srt-1.3.1-use-destdir-for-symlinks-09afc227e0880b12a98e18ee8182f89c3a80e3a6.patch
deleted file mode 100644
index 2859ed1bac3b..000000000000
--- a/net-libs/srt/files/srt-1.3.1-use-destdir-for-symlinks-09afc227e0880b12a98e18ee8182f89c3a80e3a6.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From 09afc227e0880b12a98e18ee8182f89c3a80e3a6 Mon Sep 17 00:00:00 2001
-From: Dennis Schridde <devurandom@gmx.net>
-Date: Sat, 15 Dec 2018 23:21:17 +0100
-Subject: [PATCH] CMakeLists.txt: Respect DESTDIR when creating stransmit
- symlink
-
-Fixes: #357
----
- CMakeLists.txt | 20 ++++++--------------
- scripts/haiUtil.cmake | 5 -----
- 2 files changed, 6 insertions(+), 19 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index eb2582c..fe45919 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -705,28 +705,20 @@ if ( ENABLE_CXX11 )
- # For backward compatibility with the old name
- if (SYMLINKABLE)
- set (REPLI_COMMAND create_symlink )
-+ # It appears impossible to get the filename component from the generator
-+ # expression $<TARGET_FILE:srt-live-transmit>, hence we predict it as:
-+ set (srt_live_transmit_name srt-live-transmit${CMAKE_EXECUTABLE_SUFFIX})
- else()
- set (REPLI_COMMAND copy)
-+ set (srt_live_transmit_name $<TARGET_FILE:srt-live-transmit>)
- endif()
-
- set (stransmit_path $<TARGET_FILE_DIR:srt-live-transmit>/stransmit${CMAKE_EXECUTABLE_SUFFIX})
- add_custom_command(
- TARGET srt-live-transmit
- POST_BUILD
-- COMMAND ${CMAKE_COMMAND} -E ${REPLI_COMMAND} $<TARGET_FILE:srt-live-transmit> ${stransmit_path})
--
-- if (SYMLINKABLE)
-- message(STATUS "BACKWARD COMPATIBLE 'stransmit': will use symbolic link")
-- srt_install_symlink(srt-live-transmit ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_BINDIR}/stransmit)
-- elseif(${CMAKE_MAJOR_VERSION} LESS 3)
-- message(FATAL_ERROR "Your system can't install symbolic link to 'stransmit', copy-on-install requires cmake at least 3.0.2")
-- else()
-- # This installation doesn't work with cmake earlier than 3.0
-- # (looxlike cmake 2.8 somehow doesn't have a problem with resolving the $<TARGET_FILE_DIR:...>
-- # inside the generated makefile, but does have problem with its own generated cmake_install.cmake :D)
-- message(STATUS "BACKWARD COMPATIBLE 'stransmit': will use copying")
-- install(PROGRAMS ${stransmit_path} DESTINATION ${CMAKE_INSTALL_BINDIR})
-- endif()
-+ COMMAND ${CMAKE_COMMAND} -E ${REPLI_COMMAND} ${srt_live_transmit_name} ${stransmit_path})
-+ install(FILES ${stransmit_path} DESTINATION ${CMAKE_INSTALL_BINDIR})
-
- srt_add_application(srt-file-transmit ${VIRTUAL_srtsupport})
-
-diff --git a/scripts/haiUtil.cmake b/scripts/haiUtil.cmake
-index 417128d..f60bc11 100644
---- a/scripts/haiUtil.cmake
-+++ b/scripts/haiUtil.cmake
-@@ -48,5 +48,0 @@ FUNCTION(join_arguments outvar)
--macro(srt_install_symlink filepath sympath)
-- install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink ${filepath} ${sympath})")
-- install(CODE "message(\"-- Created symlink: ${sympath} -> ${filepath}\")")
--endmacro(srt_install_symlink)
--
---
-2.20.0
-