summaryrefslogtreecommitdiff
path: root/net-libs/socket_wrapper/socket_wrapper-1.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-17 14:32:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-17 14:32:10 +0100
commit51c50bd4c895ebf56d81fecae8e45ec3b5fc3efa (patch)
tree753b6b08624c34d1ed8414bbe22c45409f7741b9 /net-libs/socket_wrapper/socket_wrapper-1.2.3.ebuild
parentbe9d77d3ac6af8f4ead98d89706f356b65578c93 (diff)
parentdeba8115d2c2af26df42966b91ef04ff4dd79cde (diff)
Merge branch 'edge' into next
Diffstat (limited to 'net-libs/socket_wrapper/socket_wrapper-1.2.3.ebuild')
-rw-r--r--net-libs/socket_wrapper/socket_wrapper-1.2.3.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/net-libs/socket_wrapper/socket_wrapper-1.2.3.ebuild b/net-libs/socket_wrapper/socket_wrapper-1.2.3.ebuild
index a34e9de9815d..1c99cfc52cc3 100644
--- a/net-libs/socket_wrapper/socket_wrapper-1.2.3.ebuild
+++ b/net-libs/socket_wrapper/socket_wrapper-1.2.3.ebuild
@@ -10,9 +10,19 @@ HOMEPAGE="https://cwrap.org/socket_wrapper.html"
SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND=""
-RDEPEND="${DEPEND}"
+BDEPEND="test? ( >=dev-util/cmocka-1.1.0 )"
+
+PATCHES=(
+ "${FILESDIR}"/1.2.4-tests-pid.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DUNIT_TESTING=$(usex test ON OFF)
+ )
+ cmake-multilib_src_configure
+}