summaryrefslogtreecommitdiff
path: root/net-libs/shairplay/shairplay-0_pre20180824.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /net-libs/shairplay/shairplay-0_pre20180824.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'net-libs/shairplay/shairplay-0_pre20180824.ebuild')
-rw-r--r--net-libs/shairplay/shairplay-0_pre20180824.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-libs/shairplay/shairplay-0_pre20180824.ebuild b/net-libs/shairplay/shairplay-0_pre20180824.ebuild
new file mode 100644
index 000000000000..f4af8a0449c9
--- /dev/null
+++ b/net-libs/shairplay/shairplay-0_pre20180824.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/juhovh/${PN}.git"
+else
+ EGIT_COMMIT="096b61ad14c90169f438e690d096e3fcf87e504e"
+ SRC_URI="https://github.com/juhovh/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Apple airplay and raop protocol server"
+HOMEPAGE="https://github.com/juhovh/shairplay"
+LICENSE="BSD LGPL-2.1 MIT
+ playfair? ( GPL-3+ )"
+
+SLOT="0"
+IUSE="alac +playfair static-libs tools"
+
+DEPEND="
+ tools? ( media-libs/libao )
+"
+
+RDEPEND="
+ alac? (
+ media-sound/alac_decoder
+ net-libs/shairplay[tools]
+ )
+ tools? (
+ dev-libs/openssl:0=
+ net-dns/avahi[mdnsresponder-compat]
+ )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with playfair) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}