summaryrefslogtreecommitdiff
path: root/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /net-libs/rpcsvc-proto/rpcsvc-proto-1.4.ebuild
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'net-libs/rpcsvc-proto/rpcsvc-proto-1.4.ebuild')
-rw-r--r--net-libs/rpcsvc-proto/rpcsvc-proto-1.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.ebuild b/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.ebuild
new file mode 100644
index 000000000000..af9ee8387e54
--- /dev/null
+++ b/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="rpcsvc protocol definitions from glibc"
+HOMEPAGE="https://github.com/thkukuk/rpcsvc-proto"
+SRC_URI="https://github.com/thkukuk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+ BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!<sys-libs/glibc-2.26"
+
+src_prepare(){
+ default
+ eautoreconf
+}
+
+src_install(){
+ default
+
+ # provided by sys-fs/quota[rpc]
+ rm "${ED%/}"/usr/include/rpcsvc/rquota.{x,h} || die
+}