summaryrefslogtreecommitdiff
path: root/net-libs/rpcsvc-proto/rpcsvc-proto-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /net-libs/rpcsvc-proto/rpcsvc-proto-1.3.1.ebuild
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'net-libs/rpcsvc-proto/rpcsvc-proto-1.3.1.ebuild')
-rw-r--r--net-libs/rpcsvc-proto/rpcsvc-proto-1.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/rpcsvc-proto/rpcsvc-proto-1.3.1.ebuild b/net-libs/rpcsvc-proto/rpcsvc-proto-1.3.1.ebuild
new file mode 100644
index 000000000000..af9ee8387e54
--- /dev/null
+++ b/net-libs/rpcsvc-proto/rpcsvc-proto-1.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="rpcsvc protocol definitions from glibc"
+HOMEPAGE="https://github.com/thkukuk/rpcsvc-proto"
+SRC_URI="https://github.com/thkukuk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+ BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!<sys-libs/glibc-2.26"
+
+src_prepare(){
+ default
+ eautoreconf
+}
+
+src_install(){
+ default
+
+ # provided by sys-fs/quota[rpc]
+ rm "${ED%/}"/usr/include/rpcsvc/rquota.{x,h} || die
+}