summaryrefslogtreecommitdiff
path: root/net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild')
-rw-r--r--net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild b/net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild
new file mode 100644
index 000000000000..1c6fe5182120
--- /dev/null
+++ b/net-libs/ripe-atlas-sagan/ripe-atlas-sagan-1.1.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python{3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN=${PN//-/.}
+DESCRIPTION="A parsing library for RIPE Atlas result strings"
+HOMEPAGE="https://atlas.ripe.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.sagan/ripe.atlas.sagan-${PVR}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+S="${WORKDIR}/${MY_PN}-${PVR}"
+
+RDEPEND="
+ dev-python/ipy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ "${RDEPEND}"
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests --verbose || die "Tests failed with ${EPYTHON}"
+}