summaryrefslogtreecommitdiff
path: root/net-libs/ntirpc/ntirpc-4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-23 12:45:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-23 12:45:14 +0000
commitc8c3804588db08dae281504dd79ef71741cd8dc3 (patch)
treec0dc730627dd25f276c533a00e6b763b8eef1f56 /net-libs/ntirpc/ntirpc-4.3.ebuild
parentdd5b71d2ad69f1887985ee1ca67b254e04157f73 (diff)
gentoo auto-resync : 23:03:2023 - 12:45:13
Diffstat (limited to 'net-libs/ntirpc/ntirpc-4.3.ebuild')
-rw-r--r--net-libs/ntirpc/ntirpc-4.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/ntirpc/ntirpc-4.3.ebuild b/net-libs/ntirpc/ntirpc-4.3.ebuild
new file mode 100644
index 000000000000..e512976e7517
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="https://github.com/nfs-ganesha/ntirpc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="
+ dev-libs/userspace-rcu:=
+ rdma? ( sys-cluster/rdma-core )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake_src_configure
+}