summaryrefslogtreecommitdiff
path: root/net-libs/ntirpc/ntirpc-4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-24 07:10:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-24 07:10:12 +0000
commita59ffccce3bf214fae9932cc42400eeeaec25c6c (patch)
tree62251d3d21f2b36c2fbc08a3343513934bc06a36 /net-libs/ntirpc/ntirpc-4.2.ebuild
parente33383d972aad8129fd4c1ee2b87f529f6efa8e9 (diff)
gentoo auto-resync : 24:11:2022 - 07:10:12
Diffstat (limited to 'net-libs/ntirpc/ntirpc-4.2.ebuild')
-rw-r--r--net-libs/ntirpc/ntirpc-4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/ntirpc/ntirpc-4.2.ebuild b/net-libs/ntirpc/ntirpc-4.2.ebuild
new file mode 100644
index 000000000000..4ef6001a06c1
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="https://github.com/nfs-ganesha/ntirpc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="
+ dev-libs/userspace-rcu:=
+ rdma? ( sys-cluster/rdma-core )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake_src_configure
+}