summaryrefslogtreecommitdiff
path: root/net-libs/nodejs/nodejs-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /net-libs/nodejs/nodejs-99999999.ebuild
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'net-libs/nodejs/nodejs-99999999.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index d8f4436a0093..3d664da6f54b 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
+EAPI=7
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-
-inherit bash-completion-r1 eutils flag-o-matic git-r3 pax-utils python-single-r1 toolchain-funcs
+inherit bash-completion-r1 flag-o-matic git-r3 pax-utils python-single-r1 toolchain-funcs
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -28,7 +26,7 @@ RDEPEND="
>=net-libs/http-parser-2.8.0:=
>=net-libs/nghttp2-1.38.0
sys-libs/zlib
- icu? ( >=dev-libs/icu-63.1:= )
+ icu? ( >=dev-libs/icu-64.2:= )
ssl? ( >=dev-libs/openssl-1.1.1:0= )
"
DEPEND="
@@ -133,7 +131,8 @@ src_compile() {
src_install() {
local LIBDIR="${ED}/usr/$(get_libdir)"
- emake install DESTDIR="${D}"
+ default
+
pax-mark -m "${ED}"usr/bin/node
# set up a symlink structure that node-gyp expects..