summaryrefslogtreecommitdiff
path: root/net-libs/nodejs/nodejs-8.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /net-libs/nodejs/nodejs-8.12.0.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'net-libs/nodejs/nodejs-8.12.0.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-8.12.0.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/net-libs/nodejs/nodejs-8.12.0.ebuild b/net-libs/nodejs/nodejs-8.12.0.ebuild
index ed7e641f54af..2e98f86fe29f 100644
--- a/net-libs/nodejs/nodejs-8.12.0.ebuild
+++ b/net-libs/nodejs/nodejs-8.12.0.ebuild
@@ -7,7 +7,7 @@ RESTRICT="test"
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"
-inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs
+inherit bash-completion-r1 eutils flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -92,6 +92,8 @@ src_prepare() {
}
src_configure() {
+ xdg_environment_reset
+
local myconf=( --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
use debug && myconf+=( --debug )
use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )