summaryrefslogtreecommitdiff
path: root/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /net-libs/nodejs/nodejs-14.16.1-r1.ebuild
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'net-libs/nodejs/nodejs-14.16.1-r1.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-14.16.1-r1.ebuild20
1 files changed, 17 insertions, 3 deletions
diff --git a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
index 02e8c08318b3..c386c0e45b7c 100644
--- a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
@@ -22,8 +22,7 @@ REQUIRED_USE="inspector? ( icu ssl )
system-icu? ( icu )
system-ssl? ( ssl )"
-# FIXME: test-fs-mkdir fails with "no such file or directory". Investigate.
-RESTRICT="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=app-arch/brotli-1.0.9
>=dev-libs/libuv-1.40.0:=
@@ -42,6 +41,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-10.3.0-global-npm-config.patch
+ "${FILESDIR}"/${PN}-12.22.1-uvwasi_shared_libuv.patch
"${FILESDIR}"/${PN}-14.15.0-fix_ppc64_crashes.patch
"${FILESDIR}"/${PN}-14.16.1-v8_icu69.patch
)
@@ -54,7 +54,15 @@ pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]]; then
if use lto; then
- tc-is-gcc || die "${PN} only supports LTO for gcc"
+ if tc-is-gcc; then
+ if [[ $(gcc-major-version) -ge 11 ]]; then
+ # Bug #787158
+ die "LTO builds of ${PN} using gcc-11+ currently fail tests and produce runtime errors. Either switch to gcc-10 or unset USE=lto for this ebuild"
+ fi
+ else
+ # configure.py will abort on this later if we do not
+ die "${PN} only supports LTO for gcc"
+ fi
fi
fi
}
@@ -215,6 +223,12 @@ src_install() {
}
src_test() {
+ # parallel/test-fs-mkdir is known to fail with FEATURES=usersandbox
+ if has usersandbox ${FEATURES}; then
+ ewarn "You are emerging ${P} with 'usersandbox' enabled." \
+ "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ fi
+
out/${BUILDTYPE}/cctest || die
"${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
}