summaryrefslogtreecommitdiff
path: root/net-libs/nghttp3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
commit5e41a38157bb40e8513e8e34426e85faba672fe7 (patch)
tree38e9365afd56c161d0e970ddf5420b2585130587 /net-libs/nghttp3
parent0ebcd2cbf178600b5eb36b2f24cdbb3d2f4a9000 (diff)
gentoo auto-resync : 14:06:2024 - 00:09:04
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/Manifest2
-rw-r--r--net-libs/nghttp3/nghttp3-1.4.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index 1b1dda07f24a..8822251cf4c6 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1,6 +1,8 @@
DIST nghttp3-1.2.0.tar.xz 387592 BLAKE2B b3ad897fda5d616a93f063bafde760eda6f597c90de6c81793abef3ff30de05bb2a06388fa868f95c0871a6592331d17a2d344c63817179ad21c6390bc0e499b SHA512 51ade6b17215eb15c92b18ad7a94b70e0a442d5968aee31ec734e5826d09ca34197e64407a1ac3f7bfb4ed1a0b3c3b58afc4a152542bacdcc4c71140931a7652
DIST nghttp3-1.3.0.tar.xz 390176 BLAKE2B 8ff17da3e53efb27b13e9ab17dba4ca27cc8fd948b160a36a0b0496f61a49c2729f1281f9a29cb8fecd4dd2c274696885a3c5e001be3dcfc30f5f1c9b6339467 SHA512 a862e7a3c3f6722b07d5437976850b2998032d1f7b9da7a49e6863d59c611ff7204c9923e8e570301a9bfbd91931a30f8f85e96cfb35481783adfc2f955a8b8c
+DIST nghttp3-1.4.0.tar.xz 389036 BLAKE2B f8292aded56c0778dc285cf7d8261494c89e70e1e2128b0196be97706b1ce45edfd885031d069990429ef82c56c4922e0fe07d7471d4851642ce5e8afaf02bb9 SHA512 39ff9418009dcf84ae58d8297f53427da91509a69ecc4fc78c4c00f0fe6bbe348f7afffeafe535ae4c02ff9f0413016b4f51de6a87d8e8c8f6b415bb7f2b0895
EBUILD nghttp3-1.2.0-r2.ebuild 742 BLAKE2B e279425fed0370a7b99265a40b05f88ee0fb26a92d6b2fcb34be2b89d501d53db508a58cffdd12e40450cc74d73a27540504119c7225d583f7ea335822eab0c8 SHA512 23a87ea01d7396498e8a5ddd9b7106451fcbd693b3670e1db1d99d9ff69d67711dbe105450ada8e6caf32f622ae392a31c74fe7807f379c89545f456f56f7dc1
EBUILD nghttp3-1.3.0.ebuild 757 BLAKE2B 47f7189cceacc6e8c745a5f3d7e99bfea2096e57767e0c256f48fd87b95793743cd6f937b796310d5457c0a8f50906ca1f0c1d30d5e5615e0e8ee05590b4606f SHA512 b4b8d39ad767f52d34e778b92866049036e482de4533da52a5d29fdf51555e95db7befb1087354365d32648f13914c6fde6a983205ce22d26c520d3f218dbc57
+EBUILD nghttp3-1.4.0.ebuild 759 BLAKE2B 74700044d5601df448522573d135434467cb72c96f1d6c7f4aaea88d6b062df6423e3e78dfabb92a835d734748e98801b54347c74e4900a0b9f2cc0eb70a65d7 SHA512 c852ea99028537ec452699825ba2460b8848b124f98006fbf968b6e275eeeeb59df4468ee41763a9fd5b36eb3789b9d3d0be314292132fb923a1d3a393fda66e
EBUILD nghttp3-9999.ebuild 742 BLAKE2B e279425fed0370a7b99265a40b05f88ee0fb26a92d6b2fcb34be2b89d501d53db508a58cffdd12e40450cc74d73a27540504119c7225d583f7ea335822eab0c8 SHA512 23a87ea01d7396498e8a5ddd9b7106451fcbd693b3670e1db1d99d9ff69d67711dbe105450ada8e6caf32f622ae392a31c74fe7807f379c89545f456f56f7dc1
MISC metadata.xml 328 BLAKE2B 6f0147cead329ef6b779485417ff33e5814b0cd86e99b571b0dc5653a7ca8f80f65fddb8b1b58fe249b7b86c0aecd32a446d415065fc70a0c72bf69651b19d25 SHA512 54e49a9c82c6a7f7a50daf557416845fa5c548f11ca243ff236105ad97903ea983436e94067c831b93ca95da154dd2561e314e96e8bde6d4678efd1adaf02f11
diff --git a/net-libs/nghttp3/nghttp3-1.4.0.ebuild b/net-libs/nghttp3/nghttp3-1.4.0.ebuild
new file mode 100644
index 000000000000..2c11c586801a
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~riscv ~x86"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="static-libs"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}