summaryrefslogtreecommitdiff
path: root/net-libs/nghttp2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /net-libs/nghttp2
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'net-libs/nghttp2')
-rw-r--r--net-libs/nghttp2/Manifest2
-rw-r--r--net-libs/nghttp2/nghttp2-1.41.0.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 4f1cf1d7010f..08e163da7d5f 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,4 +1,6 @@
DIST nghttp2-1.40.0.tar.xz 1637004 BLAKE2B 7735ba06cd0655450a6379ea33cc79e557f73b5b4b2ba746564a53e6c305aa656b62da7c3b00dbb70472dffc471271f73af0bcbfadab99406d217d1989ad052a SHA512 3f9b989c4bd9571b11bb9d59fe2dfd5596ba3962babfc836587d5047e780400a6cf46e43c602caa25ca83c03b84a1629953140d45223099b193df54a719745ce
+DIST nghttp2-1.41.0.tar.xz 1640712 BLAKE2B 8dbd5f80bb9617d792e2eece09f6cae82907ad3a14a90084578b213191015c32ac38de87d9a39246651087b5d0e9c6c624ff806a0690973b5faa8624ee033d8f SHA512 c92e8022ccc876fa311f21bc5bf5af75feff8232efb56a4b2ab198031e974d15b67c16c046188cc76552f75a1b2e7115925d6ce1e42d6f94ae482fe69727466d
EBUILD nghttp2-1.40.0.ebuild 1969 BLAKE2B 559beb9693a6fb4df96d19a57fae0884776a53673c8721b8502a72f0854133167ce42f136fdf3ad0a6366f3996f17b8b168d9f44f43d4584f6400a4c9d975e27 SHA512 6caec7f67d01715604b67a1ca1bf668490ae28e0c4b8d5d8a4606e8a92b212288e63279b04ee7fe49e44752e63a8f2965a62319f4511df505c9804b0595b501f
+EBUILD nghttp2-1.41.0.ebuild 1969 BLAKE2B 559beb9693a6fb4df96d19a57fae0884776a53673c8721b8502a72f0854133167ce42f136fdf3ad0a6366f3996f17b8b168d9f44f43d4584f6400a4c9d975e27 SHA512 6caec7f67d01715604b67a1ca1bf668490ae28e0c4b8d5d8a4606e8a92b212288e63279b04ee7fe49e44752e63a8f2965a62319f4511df505c9804b0595b501f
EBUILD nghttp2-9999.ebuild 1978 BLAKE2B 3681270a1343a533630adecc2b1edb7b32cef71368da48df558e5587d3ac85364a5e556409a920b9a0c695667b0e3bac9da1410ad1319e69d832d8a21a3fd13c SHA512 99ca054a9bf82567ce3620831b7eb42e6283545c62f8c333a5c876962fbf6f1a5b7b4acc1d9decf9307d2a6bcc25ddaaeee83b5c3f25e51a256ee3a4a2df3eed
MISC metadata.xml 492 BLAKE2B 76628f4a35c08fe73292c1c50fc6bc90dd44527ee36fb44ff4630a606fe27d9a950afe412fe1565c9eb85355c6fff13400ecb1da5d8c5de8a4765d40b23686f3 SHA512 0e67d6891d7fef473f906db3456a34b4c61f762bf87af6583ce1d477ff090cb69c749669e5cc1a3ef21ee9de3484ea1a094a5971c539edd32a0ab810a4867dcf
diff --git a/net-libs/nghttp2/nghttp2-1.41.0.ebuild b/net-libs/nghttp2/nghttp2-1.41.0.ebuild
new file mode 100644
index 000000000000..c0d775bb37c8
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.41.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=7
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RESTRICT="!test? ( test )"
+
+SSL_DEPEND="
+ !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ cxx? (
+ ${SSL_DEPEND}
+ dev-libs/boost:=[${MULTILIB_USEDEP},threads]
+ )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ ${SSL_DEPEND}
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-examples
+ --disable-failmalloc
+ --disable-python-bindings
+ --disable-werror
+ --without-cython
+ $(use_enable cxx asio-lib)
+ $(use_enable debug)
+ $(multilib_native_use_enable hpack-tools)
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ $(multilib_native_use_enable utils app)
+ $(multilib_native_use_with jemalloc)
+ $(multilib_native_use_with xml libxml2)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ if ! use static-libs ; then
+ find "${ED}"/usr -name '*.la' -delete || die
+ fi
+}