summaryrefslogtreecommitdiff
path: root/net-libs/loudmouth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /net-libs/loudmouth
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'net-libs/loudmouth')
-rw-r--r--net-libs/loudmouth/Manifest1
-rw-r--r--net-libs/loudmouth/loudmouth-1.5.3-r2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-libs/loudmouth/Manifest b/net-libs/loudmouth/Manifest
index 6daeeb1a5d1a..96266f7cceaf 100644
--- a/net-libs/loudmouth/Manifest
+++ b/net-libs/loudmouth/Manifest
@@ -2,4 +2,5 @@ AUX loudmouth-1.5.3-gcc7.patch 919 BLAKE2B 085cc7bd0c1eabe91f45c8f1fce8f52518a58
AUX loudmouth-1.5.3-skip-gtk-doc.patch 394 BLAKE2B ebcfed350077bcb67b0f7da9d0c9a31fa7483d4d927323490920f7d56b7cf78bcb6dfe04b4f59a36fac07c24267653ce8bcb2e17f2e19f4d2ad7037dca0844b5 SHA512 02ec191f33dd5601f9d875d3a5d0e1bc5baf904c18ca47c90280f860ee1449e51dbc7f2be841de85c8baf23d615574592ca8f9a913ae6b5dacd2583497bf8889
DIST loudmouth-1.5.3.tar.gz 114676 BLAKE2B 7a73e4e65046608fc8ec571b5448ab8344a8aed554fee1ecf7badd2ca5ed382ddb27e6ba7bd5d0a76d978d3079415b307f1b4ca77da450003ae936191cdbd33e SHA512 afae8b4ad1e9e5558cffa8f6b9f25331b01cfa09ea0b3defb74cac7d39477744e6d9181d3adefe242038020759df43558de0e61305fbc8e12a3b293b82856bf7
EBUILD loudmouth-1.5.3-r1.ebuild 1144 BLAKE2B c0f5f6d6d538cc0661c678a00fe31ad6370b444ee01aa999ef19b1bd2861a8e7647df192471eba6756d121a0ec3ccf5a7360eaa47e2db0682a95c4ee5ddeb34d SHA512 1dbd2faec2ffbbad86a1e651a679c6994b7d1edb3e84460f174f78fc8d333bdf238e7c3d6a6b251fb61144cfe6b34bc33f00f8d6102c4d1f5b7bf58d1ba4648b
+EBUILD loudmouth-1.5.3-r2.ebuild 1174 BLAKE2B 29524a97e8a1c4bcd2d57850615725f8ec2b927d84d261cd7acd410b0f57fd0cf21dc5593d6d80e40eca6ddc5a0acb224324adb27fb65ddf2833cb586c2dee0c SHA512 524c7f0e58c2561b1049c2cc8abf460fa086d152ec5654f1b87f189086bd73c9237bb8476a76f1781b4bbd12b6a2663ff27fa64f95558560d3cd2a50f92a4af3
MISC metadata.xml 563 BLAKE2B 11e3e68d92736cc1dc95df692d61420d487434c24d7ffa665ef7453fb0dde039b6006ce3edcae8ac0401dc15f99468133b3a4eb73c48b6ef20570558b33a90cf SHA512 b2847486aaf03b8bcd02ea006247c735da3dddac5e60f746f21d32985ef78585c347eae6cfcc8723175166455cd758014e19ccea79bdd77ede74bd36faf31c09
diff --git a/net-libs/loudmouth/loudmouth-1.5.3-r2.ebuild b/net-libs/loudmouth/loudmouth-1.5.3-r2.ebuild
new file mode 100644
index 000000000000..ad185ab77e8a
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.5.3-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="https://github.com/mcabber/loudmouth"
+SRC_URI="https://github.com/mcabber/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+
+IUSE="asyncns ssl openssl static-libs test"
+
+# Automagic libidn dependency
+RDEPEND="
+ >=dev-libs/glib-2.16:2
+ net-dns/libidn:=
+ ssl? (
+ !openssl? ( >=net-libs/gnutls-1.4.0:0= )
+ openssl? ( dev-libs/openssl:0= )
+ )
+ asyncns? ( >=net-libs/libasyncns-0.3 )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ test? ( dev-libs/check )
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc7.patch
+ "${FILESDIR}"/${P}-skip-gtk-doc.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use ssl; then
+ if ! use openssl; then
+ myconf="${myconf} --with-ssl=gnutls"
+ else
+ myconf="${myconf} --with-ssl=openssl"
+ fi
+ else
+ myconf="${myconf} --with-ssl=no"
+ fi
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with asyncns) \
+ ${myconf}
+}