summaryrefslogtreecommitdiff
path: root/net-libs/libtorrent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/libtorrent
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/Manifest6
-rw-r--r--net-libs/libtorrent/libtorrent-0.13.6-r1.ebuild61
-rw-r--r--net-libs/libtorrent/libtorrent-0.13.6.ebuild52
-rw-r--r--net-libs/libtorrent/metadata.xml12
4 files changed, 131 insertions, 0 deletions
diff --git a/net-libs/libtorrent/Manifest b/net-libs/libtorrent/Manifest
new file mode 100644
index 000000000000..0289f4c95c88
--- /dev/null
+++ b/net-libs/libtorrent/Manifest
@@ -0,0 +1,6 @@
+DIST libtorrent-0.13.6.tar.gz 781253 SHA256 2838a08c96edfd936aff8fbf99ecbb930c2bfca3337dd1482eb5fccdb80d5a04 SHA512 b8aea4060357a8a40d15d42f1f698ef6f3ebdc885000bfbfa5bf9c81af8c88b5503a107e05c214e3e8489126928d336356c5e7e0eaf836b6b84a3cf74633b050 WHIRLPOOL 9bfc9444efef33dce9792b7dc50fd150ebf7462ea656f82ed7cf1b9c3873eb94742c1e3ecdea6d1c382383ca6ebd4ac1e1ea4169328534d056944fb26c2aa4fd
+EBUILD libtorrent-0.13.6-r1.ebuild 1723 SHA256 5f55d93452d6158f8d993113b124bb576c4d098e998978a5c96b0332ba284ff9 SHA512 ba76515e588c4d2818055fcf6777e6fa1dd3df973dd0da8d32c68d1babcc7b700182f91fbf1d6eafcc7152dab1a508b4b483871e61c404f18d14e5a62f96b2f2 WHIRLPOOL 921b6f9aa7fd41f8ea29fb18792912cf287258ecdcf79c90c4018da8015e02e400f4d3f7259c7a75585c4d3bba1135cca610fefbf7ebf1503a08e3e5bd34e638
+EBUILD libtorrent-0.13.6.ebuild 1331 SHA256 bdcf15cb76a4c0eefe86f3c9f37087f5785726ed1b35ef4fcf5e8ad0dc4f2738 SHA512 2d10363590b0e224fa814964a3ff8adaf3e43f2e2ee1feb7ccf4d3ff524577aeb295e10f5fe5270bbf694f035440078c7e2caf1e3f6ca1e0231aac03ad81bac2 WHIRLPOOL e83b9c5ffccfd951c80ab34414f740a150bf01b1bff957cf47f39e1cd108b9745a561169773262d85ed6fb5db59c7a77d15bd80479753230803d825119fb1e51
+MISC ChangeLog 3951 SHA256 7dddd53f6ecc39cb71823769ac104d6b7aa50b484ba126ab251a08b7b5d049a1 SHA512 b2ac9985ff96996e306b8bafbd3b09460ad17c380ab9313452dd720da4fe900b37eb882792cdbcc9e2642750cf66ac4585a669a6a4d560e1e2f11da1e3e6b455 WHIRLPOOL e3437752a60601d9ae4779393aa34cad93ef1012d493a2269e596654bdec11d9f55e3aa4ce362d6d0c327c2abeea43b89060e2de22a7d438f9e695ae61ba727d
+MISC ChangeLog-2015 27326 SHA256 58f65ecc39872b7657cc376cf647c4de50e7f8c7a6b0a203fbb34db27b7c8755 SHA512 5c98dfdde0ed4f29699d55eb7ee325da2095610b5c22492f003fa069cd555ff180213f9657c9cf9861e72ca138cae87f55f93bb01c57961cfc14f2bf8e706aa5 WHIRLPOOL 43564cd468893bf800d17a4b6ed7af5d448775363465ef31189ddc7ad23ae6af4779550981a6403055c043110ba92328f3f3f36da5cfeba5ef68862022b30400
+MISC metadata.xml 332 SHA256 36a3895494e6514db7aad087b09ac81772f023a878587e21dc8dbe839943ac28 SHA512 24978f63ee3f16ffe25333a8f42591d317ab88a655026fa43b04feff2c629c456763520746a61dac5ac9ab0364bbde308c3734db4e3048cc184f3379cf1ef4e2 WHIRLPOOL 6c00ace826b4711c9281390af3ae74d2a102c9da43f35f8ab186a23889f6949f8eb05ae37779260521bf3bfea2089aa4ff3cb0b529ce61aa180760ccab924052
diff --git a/net-libs/libtorrent/libtorrent-0.13.6-r1.ebuild b/net-libs/libtorrent/libtorrent-0.13.6-r1.ebuild
new file mode 100644
index 000000000000..7eafcd218bef
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.13.6-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BitTorrent library written in C++ for *nix"
+HOMEPAGE="https://rakshasa.github.io/rtorrent/"
+SRC_URI="http://rtorrent.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+# The README says that the library ABI is not yet stable and dependencies on
+# the library should be an explicit, syncronized version until the library
+# has had more time to mature. Until it matures we should not include a soname
+# subslot.
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="debug ipv6 libressl ssl test"
+
+RDEPEND="
+ sys-libs/zlib
+ >=dev-libs/libsigc++-2.2.2:2
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/cppunit )"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # bug 518582
+ local disable_instrumentation
+ echo -e "#include <inttypes.h>\nint main(){ int64_t var = 7; __sync_add_and_fetch(&var, 1); return 0;}" > "${T}/sync_add_and_fetch.c" || die
+ $(tc-getCC) ${CFLAGS} -o /dev/null -x c "${T}/sync_add_and_fetch.c" >/dev/null 2>&1
+ if [[ $? -ne 0 ]]; then
+ disable_instrumentation="--disable-instrumentation"
+ fi
+
+ # configure needs bash or script bombs out on some null shift, bug #291229
+ CONFIG_SHELL=${BASH} econf \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ ${disable_instrumentation} \
+ --with-posix-fallocate
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}
diff --git a/net-libs/libtorrent/libtorrent-0.13.6.ebuild b/net-libs/libtorrent/libtorrent-0.13.6.ebuild
new file mode 100644
index 000000000000..49cf4e570c4e
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.13.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BitTorrent library written in C++ for *nix"
+HOMEPAGE="https://rakshasa.github.io/rtorrent/"
+SRC_URI="http://rtorrent.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+# The README says that the library ABI is not yet stable and dependencies on
+# the library should be an explicit, syncronized version until the library
+# has had more time to mature. Until it matures we should not include a soname
+# subslot.
+SLOT="0"
+
+KEYWORDS="amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="debug ipv6 libressl ssl test"
+
+RDEPEND="
+ sys-libs/zlib
+ >=dev-libs/libsigc++-2.2.2:2
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/cppunit )"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ # configure needs bash or script bombs out on some null shift, bug #291229
+ CONFIG_SHELL=${BASH} econf \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ --with-posix-fallocate
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}
diff --git a/net-libs/libtorrent/metadata.xml b/net-libs/libtorrent/metadata.xml
new file mode 100644
index 000000000000..0cdfd4647aee
--- /dev/null
+++ b/net-libs/libtorrent/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>perfinion@gentoo.org</email>
+ <name>Jason Zaman</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="github">rakshasa/libtorrent</remote-id>
+ </upstream>
+</pkgmetadata>