summaryrefslogtreecommitdiff
path: root/net-libs/libtorrent-rasterbar/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /net-libs/libtorrent-rasterbar/files
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'net-libs/libtorrent-rasterbar/files')
-rw-r--r--net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-asio-ssl-error.patch31
-rw-r--r--net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.76.patch59
-rw-r--r--net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-python-symbols.patch28
3 files changed, 118 insertions, 0 deletions
diff --git a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-asio-ssl-error.patch b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-asio-ssl-error.patch
new file mode 100644
index 000000000000..5c4e90ff852d
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-asio-ssl-error.patch
@@ -0,0 +1,31 @@
+https://github.com/arvidn/libtorrent/pull/6547
+
+From 61ebb3317b1f8a63fcf4d018a21dac6818ea21cf Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 31 Oct 2021 09:16:46 +0000
+Subject: [PATCH] Add missing include for get_ssl_category
+
+error::get_ssl_category is defined in boost/asio/ssl/error.hpp, so
+include it when we're building with SSL support.
+
+Bug: https://bugs.gentoo.org/820836
+
+---
+ bindings/python/src/error_code.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/bindings/python/src/error_code.cpp b/bindings/python/src/error_code.cpp
+index 2fc5f42..b947119 100644
+--- a/bindings/python/src/error_code.cpp
++++ b/bindings/python/src/error_code.cpp
+@@ -49,6 +49,7 @@ namespace boost
+
+ #include <boost/asio/error.hpp>
+ #if TORRENT_USE_SSL
++#include <boost/asio/ssl/error.hpp>
+ #include <libtorrent/ssl.hpp>
+ #endif
+ #if TORRENT_USE_I2P
+--
+2.33.1
+
diff --git a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.76.patch b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.76.patch
new file mode 100644
index 000000000000..a3cdd811e2a3
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.76.patch
@@ -0,0 +1,59 @@
+https://github.com/paullouisageneau/boost-asio-gnutls/commit/895105972e5a9318d572b147c1872f64d23e2a8e
+https://bugs.gentoo.org/820836
+https://github.com/arvidn/libtorrent/pull/6546
+
+From 895105972e5a9318d572b147c1872f64d23e2a8e Mon Sep 17 00:00:00 2001
+From: Shantanu Singh <shsi@microsoft.com>
+Date: Fri, 18 Sep 2020 14:01:39 -0700
+Subject: [PATCH] Use fully qualified std::placeholders to prevent conflicts
+ with boost::placeholders
+
+--- a/deps/asio-gnutls/include/boost/asio/gnutls/stream.hpp
++++ b/deps/asio-gnutls/include/boost/asio/gnutls/stream.hpp
+@@ -244,8 +244,7 @@ template <typename NextLayer> class stream : public stream_base
+ return;
+ }
+
+- using namespace std::placeholders;
+- m_impl->read_handler = std::bind(callable, _1, _2);
++ m_impl->read_handler = std::bind(callable, std::placeholders::_1, std::placeholders::_2);
+ m_impl->bytes_read = 0;
+ m_impl->async_schedule();
+ return callable.get_completion_result();
+@@ -293,8 +292,7 @@ template <typename NextLayer> class stream : public stream_base
+ return;
+ }
+
+- using namespace std::placeholders;
+- m_impl->write_handler = std::bind(callable, _1, _2);
++ m_impl->write_handler = std::bind(callable, std::placeholders::_1, std::placeholders::_2);
+ m_impl->bytes_written = 0;
+ m_impl->async_schedule();
+ return callable.get_completion_result();
+@@ -568,8 +566,6 @@ template <typename NextLayer> class stream : public stream_base
+
+ void async_schedule()
+ {
+- using namespace std::placeholders;
+-
+ if (!parent) return;
+ auto& next_layer = parent->m_next_layer;
+
+@@ -581,14 +577,14 @@ template <typename NextLayer> class stream : public stream_base
+ else
+ next_layer.async_wait(
+ next_layer_type::wait_read,
+- std::bind(&impl::handle_read, this->shared_from_this(), _1));
++ std::bind(&impl::handle_read, this->shared_from_this(), std::placeholders::_1));
+ }
+
+ // Start a write operation if GnuTLS wants one
+ if (want_write() && !std::exchange(is_writing, true))
+ {
+ next_layer.async_wait(next_layer_type::wait_write,
+- std::bind(&impl::handle_write, this->shared_from_this(), _1));
++ std::bind(&impl::handle_write, this->shared_from_this(), std::placeholders::_1));
+ }
+ }
+
+
diff --git a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-python-symbols.patch b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-python-symbols.patch
new file mode 100644
index 000000000000..109a6490af23
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-python-symbols.patch
@@ -0,0 +1,28 @@
+https://github.com/arvidn/libtorrent/commit/f2eefd327f1ca89b053eb1e5f4ed229efe52e47f
+https://bugs.gentoo.org/820518
+
+From: Nick Korotysh <kolchaprogrammer@list.ru>
+Date: Fri, 25 Jun 2021 22:08:00 +0300
+Subject: [PATCH] added missed sources to Python bindings CMakeLists.txt
+
+fixes libtorrent loading module issues:
+libtorrent.cpython-39-x86_64-linux-gnu.so: undefined symbol: _Z16bind_sha256_hashv
+--- a/bindings/python/CMakeLists.txt
++++ b/bindings/python/CMakeLists.txt
+@@ -49,6 +49,7 @@ Python3_add_library(python-libtorrent MODULE WITH_SOABI
+ src/entry.cpp
+ src/error_code.cpp
+ src/fingerprint.cpp
++ src/info_hash.cpp
+ src/ip_filter.cpp
+ src/magnet_uri.cpp
+ src/module.cpp
+@@ -56,6 +57,7 @@ Python3_add_library(python-libtorrent MODULE WITH_SOABI
+ src/session.cpp
+ src/session_settings.cpp
+ src/sha1_hash.cpp
++ src/sha256_hash.cpp
+ src/string.cpp
+ src/torrent_handle.cpp
+ src/torrent_info.cpp
+