summaryrefslogtreecommitdiff
path: root/net-libs/libtorrent-rasterbar/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-libs/libtorrent-rasterbar/files
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-libs/libtorrent-rasterbar/files')
-rw-r--r--net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-asio-ssl-error.patch31
-rw-r--r--net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.76.patch59
-rw-r--r--net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.77.patch37
-rw-r--r--net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-python-symbols.patch28
-rw-r--r--net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.5-boost-1.78.patch46
5 files changed, 0 insertions, 201 deletions
diff --git a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-asio-ssl-error.patch b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-asio-ssl-error.patch
deleted file mode 100644
index 5c4e90ff852d..000000000000
--- a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-asio-ssl-error.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-https://github.com/arvidn/libtorrent/pull/6547
-
-From 61ebb3317b1f8a63fcf4d018a21dac6818ea21cf Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Sun, 31 Oct 2021 09:16:46 +0000
-Subject: [PATCH] Add missing include for get_ssl_category
-
-error::get_ssl_category is defined in boost/asio/ssl/error.hpp, so
-include it when we're building with SSL support.
-
-Bug: https://bugs.gentoo.org/820836
-
----
- bindings/python/src/error_code.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/bindings/python/src/error_code.cpp b/bindings/python/src/error_code.cpp
-index 2fc5f42..b947119 100644
---- a/bindings/python/src/error_code.cpp
-+++ b/bindings/python/src/error_code.cpp
-@@ -49,6 +49,7 @@ namespace boost
-
- #include <boost/asio/error.hpp>
- #if TORRENT_USE_SSL
-+#include <boost/asio/ssl/error.hpp>
- #include <libtorrent/ssl.hpp>
- #endif
- #if TORRENT_USE_I2P
---
-2.33.1
-
diff --git a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.76.patch b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.76.patch
deleted file mode 100644
index a3cdd811e2a3..000000000000
--- a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.76.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-https://github.com/paullouisageneau/boost-asio-gnutls/commit/895105972e5a9318d572b147c1872f64d23e2a8e
-https://bugs.gentoo.org/820836
-https://github.com/arvidn/libtorrent/pull/6546
-
-From 895105972e5a9318d572b147c1872f64d23e2a8e Mon Sep 17 00:00:00 2001
-From: Shantanu Singh <shsi@microsoft.com>
-Date: Fri, 18 Sep 2020 14:01:39 -0700
-Subject: [PATCH] Use fully qualified std::placeholders to prevent conflicts
- with boost::placeholders
-
---- a/deps/asio-gnutls/include/boost/asio/gnutls/stream.hpp
-+++ b/deps/asio-gnutls/include/boost/asio/gnutls/stream.hpp
-@@ -244,8 +244,7 @@ template <typename NextLayer> class stream : public stream_base
- return;
- }
-
-- using namespace std::placeholders;
-- m_impl->read_handler = std::bind(callable, _1, _2);
-+ m_impl->read_handler = std::bind(callable, std::placeholders::_1, std::placeholders::_2);
- m_impl->bytes_read = 0;
- m_impl->async_schedule();
- return callable.get_completion_result();
-@@ -293,8 +292,7 @@ template <typename NextLayer> class stream : public stream_base
- return;
- }
-
-- using namespace std::placeholders;
-- m_impl->write_handler = std::bind(callable, _1, _2);
-+ m_impl->write_handler = std::bind(callable, std::placeholders::_1, std::placeholders::_2);
- m_impl->bytes_written = 0;
- m_impl->async_schedule();
- return callable.get_completion_result();
-@@ -568,8 +566,6 @@ template <typename NextLayer> class stream : public stream_base
-
- void async_schedule()
- {
-- using namespace std::placeholders;
--
- if (!parent) return;
- auto& next_layer = parent->m_next_layer;
-
-@@ -581,14 +577,14 @@ template <typename NextLayer> class stream : public stream_base
- else
- next_layer.async_wait(
- next_layer_type::wait_read,
-- std::bind(&impl::handle_read, this->shared_from_this(), _1));
-+ std::bind(&impl::handle_read, this->shared_from_this(), std::placeholders::_1));
- }
-
- // Start a write operation if GnuTLS wants one
- if (want_write() && !std::exchange(is_writing, true))
- {
- next_layer.async_wait(next_layer_type::wait_write,
-- std::bind(&impl::handle_write, this->shared_from_this(), _1));
-+ std::bind(&impl::handle_write, this->shared_from_this(), std::placeholders::_1));
- }
- }
-
-
diff --git a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.77.patch b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.77.patch
deleted file mode 100644
index b39f62614b2a..000000000000
--- a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.77.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-https://github.com/arvidn/libtorrent/pull/6412
-https://github.com/arvidn/libtorrent/issues/6405
-https://bugs.gentoo.org/808084
-
-From 906cedddedbdf9d98ecf2bd19340f7f17869b968 Mon Sep 17 00:00:00 2001
-From: arvidn <arvid@libtorrent.org>
-Date: Thu, 19 Aug 2021 11:54:13 +0200
-Subject: [PATCH] bump handler allocation sizes for boost-1.77 (linux)
-
----
- include/libtorrent/aux_/allocating_handler.hpp | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/include/libtorrent/aux_/allocating_handler.hpp b/include/libtorrent/aux_/allocating_handler.hpp
-index 9d826d11a1..b24349850e 100644
---- a/include/libtorrent/aux_/allocating_handler.hpp
-+++ b/include/libtorrent/aux_/allocating_handler.hpp
-@@ -122,14 +122,14 @@ namespace libtorrent { namespace aux {
- constexpr std::size_t fuzzer_write_cost = 0;
- constexpr std::size_t fuzzer_read_cost = 0;
- #endif
-- constexpr std::size_t write_handler_max_size = tracking + debug_write_iter + openssl_write_cost + fuzzer_write_cost + 152;
-- constexpr std::size_t read_handler_max_size = tracking + debug_read_iter + openssl_read_cost + fuzzer_read_cost + 152;
-- constexpr std::size_t udp_handler_max_size = tracking + 144;
-- constexpr std::size_t utp_handler_max_size = tracking + 168;
-+ constexpr std::size_t write_handler_max_size = tracking + debug_write_iter + openssl_write_cost + fuzzer_write_cost + 168;
-+ constexpr std::size_t read_handler_max_size = tracking + debug_read_iter + openssl_read_cost + fuzzer_read_cost + 168;
-+ constexpr std::size_t udp_handler_max_size = tracking + 160;
-+ constexpr std::size_t utp_handler_max_size = tracking + 184;
- constexpr std::size_t abort_handler_max_size = tracking + 72;
- constexpr std::size_t submit_handler_max_size = tracking + 72;
- constexpr std::size_t deferred_handler_max_size = tracking + 80;
-- constexpr std::size_t tick_handler_max_size = tracking + 112;
-+ constexpr std::size_t tick_handler_max_size = tracking + 128;
- #endif
-
- enum HandlerName
diff --git a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-python-symbols.patch b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-python-symbols.patch
deleted file mode 100644
index 109a6490af23..000000000000
--- a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-python-symbols.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-https://github.com/arvidn/libtorrent/commit/f2eefd327f1ca89b053eb1e5f4ed229efe52e47f
-https://bugs.gentoo.org/820518
-
-From: Nick Korotysh <kolchaprogrammer@list.ru>
-Date: Fri, 25 Jun 2021 22:08:00 +0300
-Subject: [PATCH] added missed sources to Python bindings CMakeLists.txt
-
-fixes libtorrent loading module issues:
-libtorrent.cpython-39-x86_64-linux-gnu.so: undefined symbol: _Z16bind_sha256_hashv
---- a/bindings/python/CMakeLists.txt
-+++ b/bindings/python/CMakeLists.txt
-@@ -49,6 +49,7 @@ Python3_add_library(python-libtorrent MODULE WITH_SOABI
- src/entry.cpp
- src/error_code.cpp
- src/fingerprint.cpp
-+ src/info_hash.cpp
- src/ip_filter.cpp
- src/magnet_uri.cpp
- src/module.cpp
-@@ -56,6 +57,7 @@ Python3_add_library(python-libtorrent MODULE WITH_SOABI
- src/session.cpp
- src/session_settings.cpp
- src/sha1_hash.cpp
-+ src/sha256_hash.cpp
- src/string.cpp
- src/torrent_handle.cpp
- src/torrent_info.cpp
-
diff --git a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.5-boost-1.78.patch b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.5-boost-1.78.patch
deleted file mode 100644
index 93e14963e366..000000000000
--- a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.5-boost-1.78.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From feb911a19c8a66bf13915973649d3a4f5d729f12 Mon Sep 17 00:00:00 2001
-From: arvidn <arvid@libtorrent.org>
-Date: Sun, 12 Dec 2021 21:52:15 +0100
-Subject: [PATCH] update allocator sizes for boost-1.78
-
----
- include/libtorrent/aux_/allocating_handler.hpp | 16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/include/libtorrent/aux_/allocating_handler.hpp b/include/libtorrent/aux_/allocating_handler.hpp
-index 726032e085c..7096dfd2e67 100644
---- a/include/libtorrent/aux_/allocating_handler.hpp
-+++ b/include/libtorrent/aux_/allocating_handler.hpp
-@@ -77,11 +77,11 @@ namespace libtorrent { namespace aux {
- constexpr std::size_t openssl_write_cost = 0;
- #endif
-
-- constexpr std::size_t read_handler_max_size = tracking + debug_read_iter + openssl_read_cost + 102 + 8 * sizeof(void*);
-- constexpr std::size_t write_handler_max_size = tracking + debug_write_iter + openssl_write_cost + 102 + 8 * sizeof(void*);
-- constexpr std::size_t udp_handler_max_size = tracking + debug_tick + 144 + 8 * sizeof(void*);
-- constexpr std::size_t utp_handler_max_size = tracking + debug_tick + 168 + 8 * sizeof(void*);
-- constexpr std::size_t tick_handler_max_size = tracking + debug_tick + 160;
-+ constexpr std::size_t read_handler_max_size = tracking + debug_read_iter + openssl_read_cost + 102 + 9 * sizeof(void*);
-+ constexpr std::size_t write_handler_max_size = tracking + debug_write_iter + openssl_write_cost + 102 + 9 * sizeof(void*);
-+ constexpr std::size_t udp_handler_max_size = tracking + debug_tick + 144 + 9 * sizeof(void*);
-+ constexpr std::size_t utp_handler_max_size = tracking + debug_tick + 168 + 9 * sizeof(void*);
-+ constexpr std::size_t tick_handler_max_size = tracking + debug_tick + 168;
- constexpr std::size_t abort_handler_max_size = tracking + debug_tick + 104;
- constexpr std::size_t submit_handler_max_size = tracking + debug_tick + 104;
- constexpr std::size_t deferred_handler_max_size = tracking + debug_tick + 112;
-@@ -124,12 +124,12 @@ namespace libtorrent { namespace aux {
- #endif
- constexpr std::size_t write_handler_max_size = tracking + debug_write_iter + openssl_write_cost + fuzzer_write_cost + 168;
- constexpr std::size_t read_handler_max_size = tracking + debug_read_iter + openssl_read_cost + fuzzer_read_cost + 168;
-- constexpr std::size_t udp_handler_max_size = tracking + 160;
-- constexpr std::size_t utp_handler_max_size = tracking + 184;
-+ constexpr std::size_t udp_handler_max_size = tracking + 168;
-+ constexpr std::size_t utp_handler_max_size = tracking + 192;
- constexpr std::size_t abort_handler_max_size = tracking + 72;
- constexpr std::size_t submit_handler_max_size = tracking + 72;
- constexpr std::size_t deferred_handler_max_size = tracking + 80;
-- constexpr std::size_t tick_handler_max_size = tracking + 128;
-+ constexpr std::size_t tick_handler_max_size = tracking + 136;
- #endif
-
- enum HandlerName