summaryrefslogtreecommitdiff
path: root/net-libs/libssh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-31 08:59:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-31 08:59:54 +0100
commit3b08f674e3f771b49370edb144dab0958c8cf721 (patch)
tree3673eb62859b2343bc70589f2f9d670c2eee5cc8 /net-libs/libssh
parentb1c81de4fadbd00897700a7321f03b390d952b2e (diff)
gentoo resync : 31.08.2021
Diffstat (limited to 'net-libs/libssh')
-rw-r--r--net-libs/libssh/Manifest2
-rw-r--r--net-libs/libssh/libssh-0.9.6.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/net-libs/libssh/Manifest b/net-libs/libssh/Manifest
index dd88c506f260..e354d2e0b511 100644
--- a/net-libs/libssh/Manifest
+++ b/net-libs/libssh/Manifest
@@ -1,5 +1,7 @@
AUX libssh-0.8.0-tests.patch 503 BLAKE2B 22c3527e4b06ab9a00936e84c66ed14c7163a285aa5c88cfec5543e7c7aada8ffb716e20f3d3a0fef9425e244629f0d1c35250bdb9ce454b6cb247a3537cd411 SHA512 43145c2c202510ebe5cf64b47a6963b9335a844997f986938eacb0171a129863cdbd2676b8016941c85ec8c820d0543b8ab20f6aca5af86b3506e78aa29cf7e8
DIST libssh-0.9.5.tar.xz 502876 BLAKE2B 8ea07bf25218563cbbdab31683e679f71298e2c7c9bb2430195e84892838cd55b9025ed292de65c4942ecec7d4037d5b92a414232fca6c8e41821776f4cf815c SHA512 64e692a0bfa7f73585ea7b7b8b1d4c9a7f9be59565bfd4de32ca8cd9db121f87e7ad51f5c80269fbd99545af34dcf1894374ed8a6d6c1ac5f8601c026572ac18
+DIST libssh-0.9.6.tar.xz 1053056 BLAKE2B e8565279a430786b8877386a26700a39386e908546a209815b135a2bf4ef42c37b9890dc29cda9ce6c8bfe3f3bae4942097dc794302aec767d106a45c44b811d SHA512 4040ec4af937e95be2e41313ef6d4db60b46b8d4dea10c09402398127c1d1ca8843392d207088aeee3c7ef631c6ae7b66861327dcebf78ed3af0723777619fd1
EBUILD libssh-0.9.5.ebuild 3117 BLAKE2B b05b2f0718376bcdd086cac5ea7301eed6ba29831a2219c3cfff77765476554b16867d83a7974ad03c480485c2f8b7551a4bdb18c6487011b1a62f9000063d44 SHA512 4daf780178f7293affb803614ca71f7c952fadc0cd838c33db41118bba3da15d5f8fbe8d4ce1c4085096a542957e45099ce9f895c41fbebe8ffb2ae56702eab2
+EBUILD libssh-0.9.6.ebuild 3124 BLAKE2B 24029a0dff706f3e2fc552868d66fdb52d732e00369724b0d81e01a26ca883b8d65f893a2fe6afec4c08220b60857bdd76466ed63daf1eaf21be0b145316f6b6 SHA512 fe32e4c25a05f69c5d72f99e3f8e2ab530a70187a015dfe251e18b97593aab6f51441e99e7cb2e4027fefbee7439ec4afb21ecb7ad2721331fce7341c2deb3e1
EBUILD libssh-9999.ebuild 3117 BLAKE2B 98eb87a2073ee4a86a2f339d5c37fa89dbb16e1ff6d7548b5ba6e4b051ba24180742d6c90747498c3939236c0fdbfa3d9de9ea28e077a35cfd41aa1dfcc29e47 SHA512 6a300f9e1695c444657fcd2fd19f25cc2d8ee6451076c0e039107c602f056bf23b2b3e8478ddacc5d8416dc2d4a7e383a3ff6afd858b2f4b4d337a8d235f4bf7
MISC metadata.xml 628 BLAKE2B d00b92769be46eda265251a9ed4f6193901325d1acbe7431322a8e8703bab28bee8cf37356e258fea14477afe1de039328e71d85f05d997ebbecbe632cd5f6c2 SHA512 a583a03a4c8daeaca89d51aa100b257d82b3a5483c66a81d8c5d5d9a93434fef2bc8f8cb8bd417e4593426a463cdf6d13272305e2296cc5bef37a02a9ef6a474
diff --git a/net-libs/libssh/libssh-0.9.6.ebuild b/net-libs/libssh/libssh-0.9.6.ebuild
new file mode 100644
index 000000000000..d1c1e18fe748
--- /dev/null
+++ b/net-libs/libssh/libssh-0.9.6.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Access a working SSH implementation by means of a library"
+HOMEPAGE="https://www.libssh.org/"
+
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
+else
+ SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/4" # subslot = soname major version
+IUSE="debug doc examples gcrypt gssapi mbedtls pcap server +sftp static-libs test zlib"
+# Maintainer: check IUSE-defaults at DefineOptions.cmake
+
+REQUIRED_USE="?? ( gcrypt mbedtls )"
+
+BDEPEND="
+ doc? ( app-doc/doxygen[dot] )
+"
+RDEPEND="
+ !gcrypt? (
+ !mbedtls? (
+ >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}]
+ )
+ )
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ gssapi? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ mbedtls? ( net-libs/mbedtls:=[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}] )
+"
+
+DOCS=( AUTHORS README ChangeLog )
+
+PATCHES=( "${FILESDIR}/${PN}-0.8.0-tests.patch" )
+
+RESTRICT+=" !test? ( test )"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # just install the examples, do not compile them
+ cmake_comment_add_subdirectory examples
+
+ # keyfile torture test is currently broken
+ sed -e "/torture_keyfiles/d" \
+ -i tests/unittests/CMakeLists.txt || die
+
+ # disable tests that take too long (bug #677006)
+ if use sparc; then
+ sed -e "/torture_threads_pki_rsa/d" -e "/torture_pki_dsa/d" \
+ -i tests/unittests/CMakeLists.txt || die
+ fi
+
+ sed -e "/^check_include_file.*HAVE_VALGRIND_VALGRIND_H/s/^/#DONT /" \
+ -i ConfigureChecks.cmake || die
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DWITH_NACL=OFF
+ -DWITH_STACK_PROTECTOR=OFF
+ -DWITH_STACK_PROTECTOR_STRONG=OFF
+ -DWITH_DEBUG_CALLTRACE="$(usex debug)"
+ -DWITH_DEBUG_CRYPTO="$(usex debug)"
+ -DWITH_GCRYPT="$(usex gcrypt)"
+ -DWITH_GSSAPI="$(usex gssapi)"
+ -DWITH_MBEDTLS="$(usex mbedtls)"
+ -DWITH_PCAP="$(usex pcap)"
+ -DWITH_SERVER="$(usex server)"
+ -DWITH_SFTP="$(usex sftp)"
+ -DBUILD_STATIC_LIB="$(usex static-libs)"
+ -DUNIT_TESTING="$(usex test)"
+ -DWITH_ZLIB="$(usex zlib)"
+ )
+
+ multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
+
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+ multilib_is_native_abi && use doc && cmake_src_compile docs
+}
+
+multilib_src_install() {
+ cmake_src_install
+ multilib_is_native_abi && use doc && HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+
+ use static-libs && dolib.a src/libssh.a
+
+ # compatibility symlink until all consumers have been updated
+ # to no longer use libssh_threads.so
+ dosym libssh.so /usr/$(get_libdir)/libssh_threads.so
+}
+
+multilib_src_install_all() {
+ use mbedtls && DOCS+=( README.mbedtls )
+ einstalldocs
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h,cpp}
+ fi
+}