summaryrefslogtreecommitdiff
path: root/net-libs/libssh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
commit32b8124b0a5827960601f2183a970103b3d231b7 (patch)
treefebd1cb81d2417f5452d0e21f81d06663f12caa3 /net-libs/libssh
parent89e7f1cd6dd17f245898939477ef38d45dd112b9 (diff)
gentoo auto-resync : 19:12:2023 - 07:53:49
Diffstat (limited to 'net-libs/libssh')
-rw-r--r--net-libs/libssh/Manifest2
-rw-r--r--net-libs/libssh/libssh-0.10.6.ebuild135
2 files changed, 137 insertions, 0 deletions
diff --git a/net-libs/libssh/Manifest b/net-libs/libssh/Manifest
index cbb5e6c5ba7e..623a212b445c 100644
--- a/net-libs/libssh/Manifest
+++ b/net-libs/libssh/Manifest
@@ -1,4 +1,6 @@
DIST libssh-0.10.5.tar.xz 557776 BLAKE2B de147f25fa9116743b5b2d08548c2b28b31d7b76b10e249b0a52fa19dfa09762d37ad5a5d1eaf7db89d8713144b8d3608aa2b48ce29ed324e4154493a9fcebfe SHA512 2b758f9df2b5937865d4aee775ffeafafe3ae6739a89dfc470e38c7394e3c3cb5fcf8f842fdae04929890ee7e47bf8f50e3a38e82dfd26a009f3aae009d589e0
+DIST libssh-0.10.6.tar.xz 561036 BLAKE2B 6ae1c611b685fa8ec5e5fb159f93493edf4d8ae8536300cd9a357daadc28ca2fbd8a64a22157744bc97e2e672b0b84b58e1167d7369fe88306b3581098af9f57 SHA512 40c62d63c44e882999b71552c237d73fc7364313bd00b15a211a34aeff1b73693da441d2c8d4e40108d00fb7480ec7c5b6d472f9c0784b2359a179632ab0d6c1
EBUILD libssh-0.10.5.ebuild 3494 BLAKE2B f5c2cbcf49c2c7b885e25145ae7603271e59fb7b4b24fc4475641fdaa7566716409486eae7fd43abeda28be1c2bff8cbaead6fc4bead7db9e914a5366c509b6d SHA512 52fbac5427ada924b1f4d993a660fa3ea03801ceebf4e632c1159a6e26f3921938b9aa5c87dcd5a6f3a730bf933815c3ded4281ee6cffa49813942c15e4eb44a
+EBUILD libssh-0.10.6.ebuild 3502 BLAKE2B 738826ebf2b9aaae4d5f97ee02681669f4126eff7073579a411c419c588b818ef76b366d94847eda5ad017f569dc38bc7ea2980b3d39c503ec42442932c5b533 SHA512 8cb15551cf2b7ba247e81a74e6da1f2816c7322c79d0b5d0ed11cfcd9e8bd6ba358e13169db4da17e0227943df20a1312dec2031522929ac26a5fde03ec4d847
EBUILD libssh-9999.ebuild 3502 BLAKE2B 610cc25ac1e65176f7480905017cfb1a945b49bd72903ce6f694f254d278173df285e4db5574eaf9c505ea9ae031cb6adbc7cf40918975719f250b2f6fa0f6fd SHA512 158df4438cfa23b01d76860fe185d01f20c9283ce18974cf98cabda01b5d1e7e00ec9170d8638770f6eac0e80dc2640be31ad472a5aeb93858b8d5bff6851317
MISC metadata.xml 783 BLAKE2B 79be0ef9802a5f1d58b866dd2738a721696b0a4a1b6fcf44b024c74593ba9737e4a64ce2cf1cb8ba4a17139da06ccbe2fe3d8365221159ebf797de1c4aa5b490 SHA512 f2204075966244ebc337663f1a9d010320dffeda90954c6bac69c22859fefd2b6ca0ff5809fc2d34743de6400e3d9da234c5b8a9ef211cc634f381ded5d97825
diff --git a/net-libs/libssh/libssh-0.10.6.ebuild b/net-libs/libssh/libssh-0.10.6.ebuild
new file mode 100644
index 000000000000..4872d7623ddf
--- /dev/null
+++ b/net-libs/libssh/libssh-0.10.6.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Access a working SSH implementation by means of a library"
+HOMEPAGE="https://www.libssh.org/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
+else
+ SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/4" # subslot = soname major version
+IUSE="debug doc examples gcrypt gssapi mbedtls pcap server +sftp static-libs test zlib"
+# Maintainer: check IUSE-defaults at DefineOptions.cmake
+
+REQUIRED_USE="?? ( gcrypt mbedtls )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !gcrypt? (
+ !mbedtls? (
+ >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}]
+ )
+ )
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ gssapi? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ mbedtls? ( net-libs/mbedtls:=[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}]
+ elibc_musl? ( sys-libs/argp-standalone )
+ )
+"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+DOCS=( AUTHORS CHANGELOG README )
+
+src_prepare() {
+ cmake_src_prepare
+
+ # just install the examples, do not compile them
+ cmake_comment_add_subdirectory examples
+
+ sed -e "/^check_include_file.*HAVE_VALGRIND_VALGRIND_H/s/^/#DONT /" \
+ -i ConfigureChecks.cmake || die
+
+ if use test; then
+ local skip_tests=(
+ # keyfile torture test is currently broken
+ -e "/torture_keyfiles/d"
+
+ # Tries to expand ~ which fails w/ portage homedir
+ # (torture_path_expand_tilde_unix and torture_config_make_absolute_no_sshdir)
+ -e "/torture_misc/d"
+ -e "/torture_config/d"
+ )
+
+ # Disable tests that take too long (bug #677006)
+ if use sparc; then
+ skip_tests+=(
+ -e "/torture_threads_pki_rsa/d"
+ -e "/torture_pki_dsa/d"
+ )
+ fi
+
+ if (( ${#skip_tests[@]} )) ; then
+ sed -i "${skip_tests[@]}" tests/unittests/CMakeLists.txt || die
+ fi
+
+ if use elibc_musl; then
+ sed -e "/SOLARIS/d" \
+ -i tests/CMakeLists.txt || die
+ fi
+ fi
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DWITH_NACL=OFF
+ -DWITH_STACK_PROTECTOR=OFF
+ -DWITH_STACK_PROTECTOR_STRONG=OFF
+ -DWITH_DEBUG_CALLTRACE=$(usex debug)
+ -DWITH_DEBUG_CRYPTO=$(usex debug)
+ -DWITH_GCRYPT=$(usex gcrypt)
+ -DWITH_GSSAPI=$(usex gssapi)
+ -DWITH_MBEDTLS=$(usex mbedtls)
+ -DWITH_PCAP=$(usex pcap)
+ -DWITH_SERVER=$(usex server)
+ -DWITH_SFTP=$(usex sftp)
+ -DBUILD_STATIC_LIB=$(usex static-libs)
+ # TODO: try enabling {CLIENT,SERVER}_TESTING
+ -DUNIT_TESTING=$(usex test)
+ -DWITH_ZLIB=$(usex zlib)
+ )
+
+ multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
+
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+ multilib_is_native_abi && use doc && cmake_src_compile docs
+}
+
+multilib_src_install() {
+ cmake_src_install
+ multilib_is_native_abi && use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+
+ use static-libs && dolib.a src/libssh.a
+
+ # compatibility symlink until all consumers have been updated
+ # to no longer use libssh_threads.so
+ dosym libssh.so /usr/$(get_libdir)/libssh_threads.so
+}
+
+multilib_src_install_all() {
+ use mbedtls && DOCS+=( README.mbedtls )
+ einstalldocs
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h,cpp}
+ fi
+}