summaryrefslogtreecommitdiff
path: root/net-libs/libssh2/libssh2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/libssh2/libssh2-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/libssh2/libssh2-9999.ebuild')
-rw-r--r--net-libs/libssh2/libssh2-9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libssh2/libssh2-9999.ebuild b/net-libs/libssh2/libssh2-9999.ebuild
new file mode 100644
index 000000000000..20d32d236067
--- /dev/null
+++ b/net-libs/libssh2/libssh2-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools git-r3 multilib-minimal
+
+EGIT_REPO_URI="https://github.com/libssh2/libssh2"
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="gcrypt libressl static-libs test zlib"
+
+DEPEND="
+ !gcrypt? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ )
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( NEWS README )
+
+src_prepare() {
+ default
+
+ sed -i -e 's|mansyntax.sh||g' tests/Makefile.am || die
+ ln -s ../src/libssh2_config.h.in example/libssh2_config.h.in || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # Disable tests that require extra permissions (bug #333319)
+ use test && local -x ac_cv_path_SSHD=
+
+ local crypto
+ if use gcrypt; then
+ crypto=libgcrypt
+ else
+ crypto=openssl
+ fi
+
+ ECONF_SOURCE="${S}" econf --with-crypto=${crypto}
+}