summaryrefslogtreecommitdiff
path: root/net-libs/libssh/libssh-0.9.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-libs/libssh/libssh-0.9.6.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-libs/libssh/libssh-0.9.6.ebuild')
-rw-r--r--net-libs/libssh/libssh-0.9.6.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-libs/libssh/libssh-0.9.6.ebuild b/net-libs/libssh/libssh-0.9.6.ebuild
index 3aeecf20fd7c..5283a50c1f61 100644
--- a/net-libs/libssh/libssh-0.9.6.ebuild
+++ b/net-libs/libssh/libssh-0.9.6.ebuild
@@ -14,7 +14,7 @@ if [[ "${PV}" == *9999 ]] ; then
EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
else
SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
fi
LICENSE="LGPL-2.1"
@@ -39,7 +39,9 @@ RDEPEND="
zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
- test? ( >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}] )
+ test? (
+ >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}]
+ elibc_musl? ( sys-libs/argp-standalone ) )
"
DOCS=( AUTHORS README ChangeLog )
@@ -66,6 +68,11 @@ src_prepare() {
sed -e "/^check_include_file.*HAVE_VALGRIND_VALGRIND_H/s/^/#DONT /" \
-i ConfigureChecks.cmake || die
+
+ if use test && use elibc_musl; then
+ sed -e "/SOLARIS/d" \
+ -i tests/CMakeLists.txt || die
+ fi
}
multilib_src_configure() {