summaryrefslogtreecommitdiff
path: root/net-libs/libsmi/libsmi-0.5.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-libs/libsmi/libsmi-0.5.0-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-libs/libsmi/libsmi-0.5.0-r1.ebuild')
-rw-r--r--net-libs/libsmi/libsmi-0.5.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/libsmi/libsmi-0.5.0-r1.ebuild b/net-libs/libsmi/libsmi-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..6dfe3c8358ec
--- /dev/null
+++ b/net-libs/libsmi/libsmi-0.5.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A Library to Access SMI MIB Information"
+HOMEPAGE="https://www.ibr.cs.tu-bs.de/projects/libsmi/"
+SRC_URI="https://www.ibr.cs.tu-bs.de/projects/libsmi/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static-libs"
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_test() {
+ # sming test is known to fail and some other fail if LC_ALL!=C:
+ # https://mail.ibr.cs.tu-bs.de/pipermail/libsmi/2008-March/001014.html
+ sed -i '/^[[:space:]]*smidump-sming.test \\$/d' test/Makefile
+ LC_ALL=C emake -j1 check
+}
+
+src_install() {
+ default
+
+ dodoc ANNOUNCE ChangeLog README THANKS TODO \
+ doc/{*.txt,smi.dia,smi.dtd,smi.xsd} smi.conf-example
+
+ find "${ED}" -name '*.la' -delete || die
+}