summaryrefslogtreecommitdiff
path: root/net-libs/libsearpc/libsearpc-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-23 19:09:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-23 19:09:12 +0000
commit89aeb05c8da1b0c32fb9d0cd5d202763780d5d5a (patch)
tree58e84b2fdeecbc82c9e04dc13de2d56ecc02d583 /net-libs/libsearpc/libsearpc-3.3.0.ebuild
parent87cdf8e64e5874146493d2a4a4489b08583043c3 (diff)
gentoo auto-resync : 23:11:2022 - 19:09:11
Diffstat (limited to 'net-libs/libsearpc/libsearpc-3.3.0.ebuild')
-rw-r--r--net-libs/libsearpc/libsearpc-3.3.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/libsearpc/libsearpc-3.3.0.ebuild b/net-libs/libsearpc/libsearpc-3.3.0.ebuild
new file mode 100644
index 000000000000..7702156b977b
--- /dev/null
+++ b/net-libs/libsearpc/libsearpc-3.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+# Upstream is moving tags repeatedly, then we use commit hash.
+RELEASE_COMMIT="15f6f0b9f451b9ecf99dedab72e9242e54e124eb" #tag v3.3-latest
+
+inherit autotools python-single-r1
+
+DESCRIPTION="A simple C language RPC framework"
+HOMEPAGE="https://github.com/haiwen/libsearpc/ http://seafile.com/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/${RELEASE_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.0
+ >=dev-libs/jansson-2.2.1:="
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ ')"
+
+S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
+
+src_prepare() {
+ default
+ sed -i -e "s/(DESTDIR)//" ${PN}.pc.in || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files
+ find "${ED}" -name '*.la' -delete || die
+}