summaryrefslogtreecommitdiff
path: root/net-libs/libpsl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /net-libs/libpsl
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'net-libs/libpsl')
-rw-r--r--net-libs/libpsl/Manifest2
-rw-r--r--net-libs/libpsl/libpsl-0.20.2.ebuild43
2 files changed, 25 insertions, 20 deletions
diff --git a/net-libs/libpsl/Manifest b/net-libs/libpsl/Manifest
index 1d401e12ea9c..08a04938d878 100644
--- a/net-libs/libpsl/Manifest
+++ b/net-libs/libpsl/Manifest
@@ -1,3 +1,3 @@
DIST libpsl-0.20.2.tar.gz 9228099 BLAKE2B d53b8a036ba557704c4d3a498b35fd25e3dfc466d5161040d02b7d8d47af2138cce2bdbb8203fca0591408440f1b4cfab776fe0d2ecd68959f426d903cab08d4 SHA512 fa9f6f7f0447d9fe00f5dfca5262c56ff26217eea44d0f7fc1e5d982224c41874e753f0aa06dd9e5d7d03d4f04e3dacd4f36034cc8dd0fc6e2c28b49a23e62fe
-EBUILD libpsl-0.20.2.ebuild 1255 BLAKE2B 12acd8586de06566ec80715e192d1de1f13e0607157926a31bec2a926e1ddd776a0ff54d330f469f7f58d040c856862b754829500ddd1d0a993e2c84fc727d89 SHA512 f572e03390841e4a3e0a0664d23e275b9e00ca973ea509147fa8ff35d504f25b04a458e4fb068ec96d194f8004221d278a446600ace4c75c1afe5e5d1b08846b
+EBUILD libpsl-0.20.2.ebuild 1454 BLAKE2B 28c1e1c78e913245e0210b08cfb9dddba48cd1c995222c884a1c39fe43567bd0913ab4e2d76c3bccc522162fa1a8848a7bd13a1bcd71cb4ed5501a720d243c56 SHA512 8f15cc0b55a3b7fa388fe249fe34c1158727c420f0bdbce38c591b88926191eefb5b38dd76aa99e4e1c91d20aa4be5c830ac3a3634714e325e0ac5c2563713d2
MISC metadata.xml 404 BLAKE2B 8a6b54d64c66fe2ec363e4e801973851cf7f3566b4db1752bc63f1f75d4ce7d7fbb04ecb5804e848c5fd97df9eaa55479127239e3320f49dd9db33710a015035 SHA512 7886a14efd3a12c844752f1bb2af9c72963b1e68bf2a7bb2ed7368f6df89f8f0c240aec5dfec7f40d25c1c2c7771060dc013e2032e972f45cb7d86f458c4c004
diff --git a/net-libs/libpsl/libpsl-0.20.2.ebuild b/net-libs/libpsl/libpsl-0.20.2.ebuild
index 58adc0c67916..80c11e68aac9 100644
--- a/net-libs/libpsl/libpsl-0.20.2.ebuild
+++ b/net-libs/libpsl/libpsl-0.20.2.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+PYTHON_COMPAT=(python{2_7,3_{5,6,7}})
-inherit multilib-minimal
+inherit multilib-minimal python-any-r1
DESCRIPTION="C library for the Public Suffix List"
HOMEPAGE="https://github.com/rockdaboot/libpsl"
@@ -11,13 +12,11 @@ SRC_URI="https://github.com/rockdaboot/${PN}/releases/download/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~hppa ~ia64 ~s390 ~sparc ~x86"
IUSE="icu +idn +man"
-REQUIRED_USE="^^ ( icu idn )"
-
RDEPEND="
- icu? ( dev-libs/icu:=[${MULTILIB_USEDEP}] )
+ icu? ( !idn? ( dev-libs/icu:=[${MULTILIB_USEDEP}] ) )
idn? (
dev-libs/libunistring[${MULTILIB_USEDEP}]
net-dns/libidn2:=[${MULTILIB_USEDEP}]
@@ -28,33 +27,39 @@ DEPEND="
${RDEPEND}
"
BDEPEND="
+ ${PYTHON_DEPS}
dev-util/gtk-doc-am
sys-devel/gettext
virtual/pkgconfig
man? ( dev-libs/libxslt )
"
+pkg_pretend() {
+ if use icu && use idn ; then
+ ewarn "\"icu\" and \"idn\" USE flags are enabled."
+ ewarn "Using \"idn\"."
+ fi
+}
+
multilib_src_configure() {
local myeconfargs=(
--disable-asan
--disable-cfi
- --didable-ubsan
+ --disable-ubsan
$(use_enable man)
)
- if use icu || use idn ; then
- if use icu ; then
- myeconfargs+=(
- --enable-builtin=libicu
- --enable-runtime=libicu
- )
- fi
- if use idn ; then
- myeconfargs+=(
- --enable-builtin=libidn2
- --enable-runtime=libidn2
- )
- fi
+ # Prefer idn even if icu is in USE as well
+ if use idn ; then
+ myeconfargs+=(
+ --enable-builtin=libidn2
+ --enable-runtime=libidn2
+ )
+ elif use icu ; then
+ myeconfargs+=(
+ --enable-builtin=libicu
+ --enable-runtime=libicu
+ )
else
myeconfargs+=( --disable-runtime )
fi