summaryrefslogtreecommitdiff
path: root/net-libs/libpsl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-libs/libpsl
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-libs/libpsl')
-rw-r--r--net-libs/libpsl/Manifest4
-rw-r--r--net-libs/libpsl/libpsl-0.21.0.ebuild3
-rw-r--r--net-libs/libpsl/libpsl-0.21.1.ebuild71
3 files changed, 76 insertions, 2 deletions
diff --git a/net-libs/libpsl/Manifest b/net-libs/libpsl/Manifest
index 13de7c9a8519..b2b3e2541ba7 100644
--- a/net-libs/libpsl/Manifest
+++ b/net-libs/libpsl/Manifest
@@ -1,3 +1,5 @@
DIST libpsl-0.21.0.tar.gz 9217951 BLAKE2B fd93b71ae4969bb920af26e10e0e419dab62db37197046b0f4e4a0e009a150582df6d4c8fe33218fa8be869e6ad9688d3c325c3f635da5560e29269daa461668 SHA512 165c4f0b0640a813d512bd916e1532e32e43c8c81a5efd048f3a5b07b1b3c9129b4c4b5008b8b11a7c1b3914caea17564321389cd350bf1d687d53a97f2afa4d
-EBUILD libpsl-0.21.0.ebuild 1471 BLAKE2B e47eecfd4d43860a67c74646a52eb91e065bcbd40dcb5904a469dac61cce5a174053cb0cd35b6c494ad39c2d5aec6e824a6e77b24a14e14949e40dadaebfae43 SHA512 8ca2066bce3f979d9d63a175fb1fdf75b66ef222051b868f09d0e7ee08719231169bb16ce04e500e4cd95dbc3f1ac19370e062b22c9a4d12930f823705a7d44f
+DIST libpsl-0.21.1.tar.gz 9199351 BLAKE2B 87c72651303a7870fd3f742e9ce8028e0dd48d3ded78ae7dea317ce54b98975f372429399b6a2d6746fd8e074d6a3ed13772b6c173f96c3a86aa7d726fd75586 SHA512 a5084b9df4ff2a0b1f5074b20972efe0da846473396d27b57967c7f6aa190ab3c910b4bfc4f8f03802f08decbbad5820d850c36ad59610262ae37fe77de0c7f5
+EBUILD libpsl-0.21.0.ebuild 1477 BLAKE2B 9daf618050814bc285f0f0d3fffd83df06a3976881f1eb218db49300725e9d975b8cec288915f6a184e59d0c2a1c4079a26ee74067654380deb8c1ada8e20fb6 SHA512 6ba438b27e054eddca44a9d233f39ccb584f8f84791b2e01f21bcec64cb5e127e30c3105a650169bdb6d11d7aa4fde44cc2cd1c87620c684a7d6091ffc2c03e7
+EBUILD libpsl-0.21.1.ebuild 1487 BLAKE2B aaf2af0a6f3dc074fdc859a3dc91961d7a99036701541a01fde1b9c035e6909f7bc922f4e16ae96e5e71ae10e53a3acc4699132644cd60abac77376d5f698331 SHA512 20c55514cbb7d39528cf0607da8d080aee842f4f6c1113b6f06b9bd8bf58d78476e00375c83a7041522d48ab97fe473c3f4b650e014aee8292925fb6672b6a4d
MISC metadata.xml 404 BLAKE2B 8a6b54d64c66fe2ec363e4e801973851cf7f3566b4db1752bc63f1f75d4ce7d7fbb04ecb5804e848c5fd97df9eaa55479127239e3320f49dd9db33710a015035 SHA512 7886a14efd3a12c844752f1bb2af9c72963b1e68bf2a7bb2ed7368f6df89f8f0c240aec5dfec7f40d25c1c2c7771060dc013e2032e972f45cb7d86f458c4c004
diff --git a/net-libs/libpsl/libpsl-0.21.0.ebuild b/net-libs/libpsl/libpsl-0.21.0.ebuild
index 2db775b91e56..8470caabd80a 100644
--- a/net-libs/libpsl/libpsl-0.21.0.ebuild
+++ b/net-libs/libpsl/libpsl-0.21.0.ebuild
@@ -42,6 +42,7 @@ multilib_src_configure() {
--disable-asan
--disable-cfi
--disable-ubsan
+ --disable-static
$(use_enable man)
)
@@ -66,5 +67,5 @@ multilib_src_configure() {
multilib_src_install() {
default
- find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+ find "${ED}" -type f -name "*.la" -delete || die
}
diff --git a/net-libs/libpsl/libpsl-0.21.1.ebuild b/net-libs/libpsl/libpsl-0.21.1.ebuild
new file mode 100644
index 000000000000..16b8ab704fb1
--- /dev/null
+++ b/net-libs/libpsl/libpsl-0.21.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6,7,8})
+inherit multilib-minimal python-any-r1
+
+DESCRIPTION="C library for the Public Suffix List"
+HOMEPAGE="https://github.com/rockdaboot/libpsl"
+SRC_URI="https://github.com/rockdaboot/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="icu +idn +man"
+
+RDEPEND="
+ icu? ( !idn? ( dev-libs/icu:=[${MULTILIB_USEDEP}] ) )
+ idn? (
+ dev-libs/libunistring[${MULTILIB_USEDEP}]
+ net-dns/libidn2:=[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ man? ( dev-libs/libxslt )
+"
+
+pkg_pretend() {
+ if use icu && use idn ; then
+ ewarn "\"icu\" and \"idn\" USE flags are enabled."
+ ewarn "Using \"idn\"."
+ fi
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-asan
+ --disable-cfi
+ --disable-ubsan
+ --disable-static
+ $(use_enable man)
+ )
+
+ # Prefer idn even if icu is in USE as well
+ if use idn ; then
+ myeconfargs+=(
+ --enable-builtin=libidn2
+ --enable-runtime=libidn2
+ )
+ elif use icu ; then
+ myeconfargs+=(
+ --enable-builtin=libicu
+ --enable-runtime=libicu
+ )
+ else
+ myeconfargs+=( --disable-runtime )
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ default
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}