summaryrefslogtreecommitdiff
path: root/net-libs/libpcap/libpcap-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-30 14:17:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-30 14:17:35 +0000
commit363e9b282b6bd3908c2a2b56c894d785cf2fb94d (patch)
tree825865c522e3eef6c98253eb4fdc7cef1d175980 /net-libs/libpcap/libpcap-9999.ebuild
parenta21eae5570ee23ff259ccee6adc402fa27578a83 (diff)
gentoo auto-resync : 30:12:2022 - 14:17:35
Diffstat (limited to 'net-libs/libpcap/libpcap-9999.ebuild')
-rw-r--r--net-libs/libpcap/libpcap-9999.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/net-libs/libpcap/libpcap-9999.ebuild b/net-libs/libpcap/libpcap-9999.ebuild
index ddd15be165fc..6f83d33095c3 100644
--- a/net-libs/libpcap/libpcap-9999.ebuild
+++ b/net-libs/libpcap/libpcap-9999.ebuild
@@ -25,7 +25,8 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="bluetooth dbus netlink rdma remote static-libs usb yydebug"
+IUSE="bluetooth dbus netlink rdma remote static-libs test usb yydebug"
+RESTRICT="!test? ( test )"
RDEPEND="
bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
@@ -37,8 +38,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
BDEPEND="
- sys-devel/flex
app-alternatives/yacc
+ sys-devel/flex
dbus? ( virtual/pkgconfig )
"
@@ -48,6 +49,7 @@ fi
PATCHES=(
"${FILESDIR}"/${PN}-1.10.0-usbmon.patch
+
"${FILESDIR}"/${PN}-1.10.1-pcap-config.patch
)
@@ -62,8 +64,10 @@ src_prepare() {
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" \
- econf \
+ # bug #884275
+ export LEX=flex
+
+ ECONF_SOURCE="${S}" econf \
$(use_enable bluetooth) \
$(use_enable dbus) \
$(use_enable rdma) \
@@ -76,6 +80,11 @@ multilib_src_configure() {
multilib_src_compile() {
emake all shared
+ use test && emake testprogs
+}
+
+multilib_src_test() {
+ testprogs/findalldevstest || die
}
multilib_src_install_all() {